4

I have been attempting to install /e/ OS on a Fairphone 4 in accordance with these instructions: https://doc.e.foundation/devices/FP4/install and I am stuck on Step 6 of Unlocking the Bootloader. No matter what I do, I get results like this when attempting to use the fastboot flashing ... commands:

./fastboot flashing get_unlock_ability
FAILED (remote: 'Unrecognized command flashing get_unlock_ability')
fastboot: error: Command failed

I've gone through multiple Troubleshooting guides. None have helped. Here are some of the notable details and things I have tried:

  • I've tried on both MacOS and Windows, the result is the same.
  • I've tried multiple different USB-C cables with both MacOS and Windows.
  • I've tried installing the tools using Homebrew on Mac, then uninstalled, and installed using the official Android Studio process. The result is still the same.
  • I've gone through and switched out the default driver on Windows for the Google one, as recommended here: https://www.reddit.com/r/fairphone/comments/slk2qd/e_installtion_troubleshooting_guide_fastboot/ the result is still the same.
  • ADB works perfectly.
  • The device "lists" perfectly:
    ./adb devices -l
    List of devices attached
    XXXXXXXX               device usb:2097152X product:FP4eea model:FP4 device:FP4 transport_id:14
    
  • I have done the OEM unlock process.
  • Fastboot can clearly see the device when I boot to fastboot (./adb reboot fastboot):
    ./fastboot devices
    XXXXXXXX      fastboot
    
  • Version information in case it helps
    ./fastboot --version
    fastboot version 33.0.2-8557947
    Installed as /Users/XXXXXXXX/Library/Android/sdk/platform-tools/fastboot
    

I'm clearly missing something, but I've gone over the instructions and various troubleshooting guides in detail and I cannot figure out what I missed. Does anyone have any ideas?

0

1 Answer 1

4

You are in the wrong fastboot, fastbootd (with the d at the end!) is fastboot in userspace, what you want is the "real" fastboot also called bootloader.

Either select "Reboot to bootloader" in fastbootd or reboot the phone with fastboot reboot bootloader.

Thx @ hirnsushi

3
  • OK, but that introduces a different issue, when I go into the "real fastboot" (it does indeed say "FastBoot Mode" rather than FastbootD at the top) I cannot execute any commands. When I run fastboot devices it just hangs and never returns. Is it an issue if the FastBoot Mode screen says "Device State - locked" at the bottom?
    – RedHack
    Commented Jun 4, 2022 at 15:34
  • nvm... apparently fastboot devices doesn't work, but fastboot flash unlock works just fine. Thank you!
    – RedHack
    Commented Jun 4, 2022 at 15:47
  • that's strange. is it reproducable?
    – alecxs
    Commented Jun 4, 2022 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .