5

I am trying to flash LineageOS 18.1 GO custom ROM on my Samsung Galaxy Grand Prime. The model is gprimeltexx, and TWRP works. When I try to flash the ROM, it gives me this error:

E3004: This package is for device: gprimeltexx,fortunafz,grandprimelte,grandprimeltexx; this device is .

So it says that it is for my model, but it says "This device is ." So it doesn't report any model. Is there any way to fix that?

8
  • Possible dupe: E3004: This package is for device: gts210vewifi; this device is, looks like it's related to outdated TWRP? Which TWRP version did you flash?
    – Andrew T.
    Commented Jun 5, 2022 at 8:02
  • modify the installer and comment out the line, or set property on cmd line
    – alecxs
    Commented Jun 5, 2022 at 8:48
  • The latest version available on twrp.me, so its this version twrp.me/samsung/gprimeltexx.html Commented Jun 5, 2022 at 9:54
  • 1
    in TWRP terminal type 'setprop ro.product.device gprimeltexx' or delete the line with E3004 error message from lineage-18.1-20220120-UNOFFICIAL-gprimeltexx-V6stable.zip/META-INF/com/google/android/updater-script file with Notepad++
    – alecxs
    Commented Jun 5, 2022 at 16:34
  • 1
    Looks like alecxs's comment solved this, which is great to know! However, that made me wonder why the build prop missing this value. Did you perhaps alter it before?
    – Andrew T.
    Commented Jun 7, 2022 at 8:19

1 Answer 1

3

in TWRP terminal type 'setprop ro.product.device gprimeltexx'

This fixed my issue. Now all the roms I tried to flash now see my Samsung Galaxy Grand Prime as gprimeltexx.

Thanks everyone for help

3
  • In my case this did not fix it, the property was already set, and problem also remained. For me (device a3ulte) a fix was to update the TWRP from 3.0.2-1-ashyx to 3.3.1-1.ashyx Commented Jul 15, 2023 at 17:14
  • 1
    the proper way would be to use getprop ro.product.device and see if it reports something. if so, update the recovery and double check if you've got the correct ROM. -- if it reports nothing (and you are sure about the device name - perhaps getprop ro.bootloader can give a hint), use the mentioned command to set it. Commented Jan 18 at 17:10
  • Thank you! I accidentally deleted /system/Build.prop and struggled for too long trying to fix the problem. You are a lifesaver
    – TAbdiukov
    Commented Feb 8 at 7:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .