5

That's already been discussed on Hacker News, however the question remains:

  • How can you learn the permissions required by a new app without installing it?
  • How can you learn the new permissions required by an app update again without installing it?

Google has hidden app permissions both from the Google Play app and the Google Play website in the middle of May 2022 and replaced it with pretty inane "Data Safety". No one has paid attention, I've even approached at least three news outlets including Android Police, 9to5 Google, and Ars Technica - no one cared. It's a crazy serious issue and I'm appalled I'm the only person among two billion Android users who've noticed the abrupt change.

If [an] APK [file] is available on the Internet it is a solved issue, however it's often not the case, especially for paid apps.

9
  • Possible dupe: How to find app permissions in the new Google Play Store web version? (no proper answers yet. karthik's comment mentioned that the permissions are still visible from the Play Store app and I personally have confirmed it, while Firelord's comment is a potential alternative workaround)
    – Andrew T.
    Commented Jun 5, 2022 at 14:35
  • Nothing is visible in my app - it mirrors what's seen on the play website. AppBrain: appbrain.com/app/diablo-immortal/com.blizzard.diablo.immortal -> No permissions found. Various APK explorers? I've said exactly why it can't work for me. Commented Jun 5, 2022 at 14:52
  • Re: Play Store app, could you double-check by tapping the "About this app/game" header and then scroll down to the bottom for "App permissions"? I couldn't check for Diablo Immortal because it's not released yet in my country, but permissions are still shown for other games/apps from there. Otherwise, perhaps my Play Store app hasn't been updated? (currently v30.6.16-21 [O] [PR] 448548437)
    – Andrew T.
    Commented Jun 5, 2022 at 15:05
  • 1
    In the Google Play app version 30.6.16-21 [0] [PR] 448548437 - nothing is visible. i.imgur.com/7GRZZcg.png No idea what app version you're using. This is not what I see, it's now completely replaced with useless Data Safety. Commented Jun 5, 2022 at 15:37
  • 1
    ArtemS.Tashkinov A friend of mine has Play Store with same build as @AndrewT. has and he was able to see "App Permissions" too. Perhaps this is region related build variation. It is possible a new build update would remove this category for us too.
    – Firelord
    Commented Jun 5, 2022 at 16:34

2 Answers 2

4

It is possible that Google has not killed or restricted off-the-record APIs which allowed Play Store to get app permissions info back in the day. This API might be what Raccoon and Aurora Store are able to access to still successfully show app permissions for apps without installing them.

Aurora Store

Install it from F-Droid, setup a pseudo account, search your app, scroll down on the app page, tap Permission (worked on v4.1.1).

See example here.

Raccoon APK Downloader

Raccoon is a desktop-only Java app. You need Java runtime installed to run this app. See its user guide for your OS specific setup.

Once it is setup, search your app, click on the app entry, and in the bottom left click on Permission to see Permissions (worked on v4.20.0).

enter image description here

0
2

Since July 21, 2022, Google has added back permission details on the Play Store.

In a tweet by the official Android Developers account (@AndroidDev),

Privacy and transparency are core values in the Android community. We heard your feedback that you find the app permissions section in Google Play useful, and we've decided to reinstate it. The app permissions section will be back shortly.

As of September 2022, this has been added back to both web and app versions on the original location:

  • Web: About this app - Permissions - View details
  • App: About this app - App permissions - See More
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .