5

That's already been discussed on Hacker News, however the question remains:

  • How can you learn the permissions required by a new app without installing it?
  • How can you learn the new permissions required by an app update again without installing it?

Google has hid app permissions both from the Google Play app and the Google Play website in the middle of May, 2022 and replaced it with pretty inane "Data Safety". No one has paid attention, I've even approached at least three news outlets including Android Police, 9to5 Google and Ars Technica - no one cared. It's a crazy serious issue and I'm appalled I'm the only person among two billion Android users who's noticed the abrupt change.

If [an] APK [file] is available on the Internet it is a solved issue, however it's often not the case especially for paid apps.

9
  • Possible dupe: How to find app permissions in the new Google Play Store web version? (no proper answers yet. karthik's comment mentioned that the permissions are still visible from the Play Store app and I personally have confirmed it, while Firelord's comment is a potential alternative workaround)
    – Andrew T.
    Jun 5 at 14:35
  • Nothing is visible in my app - it mirrors what's seen on the play website. AppBrain: appbrain.com/app/diablo-immortal/com.blizzard.diablo.immortal -> No permissions found. Various APK explorers? I've said exactly why it can't work for me. Jun 5 at 14:52
  • Re: Play Store app, could you double-check by tapping the "About this app/game" header and then scroll down to the bottom for "App permissions"? I couldn't check for Diablo Immortal because it's not released yet in my country, but permissions are still shown for other games/apps from there. Otherwise, perhaps my Play Store app hasn't been updated? (currently v30.6.16-21 [O] [PR] 448548437)
    – Andrew T.
    Jun 5 at 15:05
  • 1
    In the Google Play app version 30.6.16-21 [0] [PR] 448548437 - nothing is visible. i.imgur.com/7GRZZcg.png No idea what app version you're using. This is not what I see, it's now completely replaced with useless Data Safety. Jun 5 at 15:37
  • 1
    ArtemS.Tashkinov A friend of mine has Play Store with same build as @AndrewT. has and he was able to see "App Permissions" too. Perhaps this is region related build variation. It is possible a new build update would remove this category for us too.
    – Firelord
    Jun 5 at 16:34

1 Answer 1

4

It is possible that Google has not killed or restricted off-the-record APIs which allowed Play Store to get app permissions info back in the day. This API might be what Raccoon and Aurora Store are able to access to still successfully show app permissions for apps without installing them.

Aurora Store

Install it from F-Droid, setup a pseudo account, search your app, scroll down on the app page, tap Permission (worked on v4.1.1).

See example here.

Raccoon APK Downloader

Raccoon is a desktop-only Java app. You need Java runtime installed to run this app. See its user guide for your OS specific setup.

Once it is setup, search your app, click on the app entry, and in the bottom left click on Permission to see Permissions (worked on v4.20.0).

enter image description here

3
  • 1
    This is crazy, the Aurora store app shows updates for the apps that Google Play Store thinks have no updates. What is this sorcery?? I know about how updates are distributed in waves, but this app shows updates for the apps that were released over a week ago and which the Google Play app seemingly ignores. Is it fetching betas? Jun 5 at 17:45
  • @ArtemS.Tashkinov I don't really know about this. Might be a good idea to mail developer and ask him about this. :)
    – Firelord
    Jun 5 at 17:50
  • Updated all of them: yes, they are all brand new but haven't yet been globally distributed/allowed. Nice. @Firelord one last question: do you know an apps which show the permissions of installed apps grouped by permissions? There are quite a few in Google Play but they are all quite stupid and basic, I want to see all the permissions not just "popular" ones. Jun 5 at 18:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .