1

I have just been setting up Android 12L on my Raspberry Pi 4 Model B. After I installed Google Play onto the Raspberry Pi, no matter how hard I try fixing it, all Google services still say it is offline even when it is connected to ethernet and WiFi (separately).

Help?

5
  • Just to clarify: is the same Wi-Fi/ethernet connection using other devices possible to connect to Google services? (ping/telnet/etc.)
    – Andrew T.
    Jun 8 at 3:06
  • Have you checked adb logcat for errors? As there is no official Android for Raspberry what custom ROM have you used? Were the Google play services already integrated or have you installed them yourself (what what variant/package have you installed).
    – Robert
    Jun 8 at 7:20
  • You can find a list of servers used by Android and Google Play Store/Services in this answer. Check them if you can resolve their DNS name and if you are able to connect to them via https.
    – Robert
    Jun 8 at 11:30
  • 1. The only other google device i had was the old rom that the same raspberry pi had 2. No. 3. I had to manually install NikGApps.
    – Saturanium
    Jun 8 at 20:23
  • So i just tried reinstalling Android 12l with another gapps file and i still had the same problem
    – Saturanium
    Jun 8 at 22:45

1 Answer 1

0

So... Turns out that I needed to enable WiFi access to google play and all other corresponding apps manually by going to Settings > Apps > [app name; particularly Google Play Store] > Mobile Data & WiFi and then turn on Allow Network Access. I didn't even know it was that simple.

2
  • Good to know that you found the solution. Interestingly, looks like there's no "Allow Network Access" on Pixel 3a Android 12, only "Background data" and "Unrestricted data usage". I'd assume this was added by the maker of the ROM for the Raspberry Pi...? Could you mention the name of the ROM?
    – Andrew T.
    Jun 12 at 6:32
  • 1
    I don’t know the exact name of the rom, all I know is that it is a LineageOS fork made specifically for all Raspberry Pi 4 models. That is interesting though that on other Android phones that they don’t have that option. Must be a Raspberry Pi exclusive.
    – Saturanium
    Jun 13 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .