1

I have two identical 64 gig microSD cards I bought three weeks ago. They both work fine in my Canon IXUS camera and they both work fine in my year-old M1 MacBook Air.

But only one works in my new Redmi 10C phone. The phone prompts me to format the other one.

I use the same USB C to USB A and USB A to microSD adapters on both. I've tried removing and re-inserting several times. I've swapped them from device to device several times. The same one consistently works on the laptop and camera and not the phone.

I have a hunch it may have been removed without ejecting. When I had Windows laptops they would prompt me to fix media that had not been ejected. I'm wondering if macOS does not do this. Perhaps because such media always uses a FAT format and not any Apple format, for maximum compatibility across devices. I don't have access to any devices at the moment besides these three.

Is there perhaps some way to get a more detailed technical diagnostic about what could be wrong with the microSD? Using either the phone or the Mac?

6
  • 1
    As far as I know by definition all SD-cards with a size of 64GB+ come exFAT formated by default. Unfortunately exFAT support is not present in all phones. Some have full support, some only- read-only and some no support at all. Check the SD-cards for the sued file-system.
    – Robert
    Jun 9, 2022 at 14:25
  • @Robert can that be checked on Andry? I know I can do it later on the laptop. Still odd since I bought the two cards together and used them straight from their packs without ever reformatting. Jun 9, 2022 at 14:28
  • I checked both with Disk Utility on the Mac and both are exFAT. I hit the First Aid button for each one. It was almost instant and did not mention any problems found with either. When I tested them both on the phone still one worked fine and I was prompted to format the other! Jun 9, 2022 at 15:38
  • 1
    make backup to PC, format in Android and restore backup
    – alecxs
    Jun 9, 2022 at 19:34
  • so do I understand right, you always hot-swapped SD Cards before?
    – alecxs
    Jun 10, 2022 at 9:06

1 Answer 1

1

I found a counterintuitive solution!

I tried to check and repair the microSD cards' extFAT filesystems on my Mac using the commandline tool fsck_exfat. I was surprised that this failed and it also failed on my good microSD card which resulted in both cards now not being recognized by the phone though both still worked perfectly on the Mac and the camera.

While hunting for answers on why the attempts to fix the exFAT failed on the Mac and whether I could do anything like fsck on a non-jailbroken Android, I came across some comments that fsck is not necessary on modern Android because the system checks all drives on boot-up.

This gave me the idea of powering off the phone, connecting the SD card via the usual pair of adaptors, then powering the phone back on.

This actually worked and both cards are now working 100% on phone, camera, and laptop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .