1

I'm trying to remove a few apps that came pre-installed on my TCL 30XE 5G. I read online that I could use the... ADB, SDK, something like that, platform tools? So I downloaded those, got the files linked to my phone with USB Debugging, and tried the uninstall commands. But nothing worked, and I'm stumped. I tried using the adb shell command first, and tried it without, but it didn't make a difference.

Here are some examples of what I tried, and what the cmd said in response:

  • pm uninstall --user 0 com.google.android.apps.podcasts gave Failure User version can not delete system package [com.google.android.apps.podcasts]

  • pm uninstall com.google.android.apps.podcasts gave Failure to remove user owner's system package :com.google.android.apps.podcasts

Does anyone have any suggestions on what else I can try? Bear in mind this is my first ever smartphone, so you may have to explain things like I'm five. Any help anyone can provide would be greatly appreciated.

2
  • Are you able to run any of these commands? pm hide --user 0 com.google.android.apps.podcasts OR pm disable-user --user 0 com.google.android.apps.podcasts
    – Firelord
    Jun 12 at 7:24
  • The disable command works, although I could already disable the app from the apps menu. The hide command though, gives the following error: link
    – Darkexxod
    Jun 17 at 23:11

0

You must log in to answer this question.

Browse other questions tagged .