0

S22 with Android12 here. I am trying to install a root CA so that I could access my internal websites using HTTPS. I seem to be having unexpected trouble doing that.

So far trying to do it by going: Settings/Biometrics.../Other.../Install from device storage/CA Certificate/Install Anyway

  • First off, when I copy certificate to internal storage, it is not visible to said installer until I reboot the phone. Annoying, but oh well, I only do it once
  • Once this installer sees the cert, it will not import it. "Private key required to install certificate" toast will pop-up after that.
  • Exactly same happens when I try to click on certificate in 'Files' app and choose "Certificate installer"

I tried to use following formats:

  • cer
  • pem (basically cer file renamed to pem)
  • p12 or pfx (same file, rename) - it asks me for password but unable to decrypt
  • pem/cer containing not only a CA root, but also a device certificate signed by said CA root and it does have private key

Phone not rooted

One thing I never tried and will not try is to export CA certificate with private key (phone has no business knowing CA's private key).

Any ideas?

1
  • P12/PFX files can be encrypted using different algorithms. I would assume that Android only supports the old 3DES encryption which was the standard since a about a year in Java. If you try to open a P12 file encrypted with AES and the software only supports 3DES then no matter which password you enter it will always fail.
    – Robert
    Jun 21 at 16:42

1 Answer 1

1

Solved: certificate installation worked using "Install from device storage" when I placed cert into "Downloads"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .