0

S22 Android 12 device here.

I have my own DNS server on a local network. Phone seems to pick up local DNS, but it will not address devices using fully-qualified name. Example (in adb):

g0q:/ $ ping nas.mydomain.local                                                                                                                                                         
ping: unknown host nas.mydomain.local
2|g0q:/ $ ping nas                                                                                                                                                                        
PING nas.mydomain.local (10.1.1.26) 56(84) bytes of data.
64 bytes from 10.1.1.26: icmp_seq=1 ttl=64 time=2.41 ms
64 bytes from 10.1.1.26: icmp_seq=2 ttl=64 time=13.4 ms
64 bytes from 10.1.1.26: icmp_seq=3 ttl=64 time=10.7 ms
64 bytes from 10.1.1.26: icmp_seq=4 ttl=64 time=16.1 ms

Same is happening in firefox and other apps. I can access host via https://hostname, but not https://hostname.mydemain.local. Anyone knows what magic is happening here and how to turn it off?

UPDATE: what I suspect might be happening is that .local domain seems to have a special meaning. I am not sure what is different in Samsung implementation, since GrapheneOS (also based on android 12) handles these hostnames fine. If someone has any suggestions how to disable this feature, please let me know

1
  • Have you checked DNS access log on your server? Then you will see what DNS queries were sent.
    – Robert
    Jun 21 at 18:16

1 Answer 1

0

The reason indeed was that domain ended with .local. I configured several servers to use .home domain name, issues them new certs, and they work resolving properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .