I'm trying to connect a gamepad with my mobile but it is not connecting.

  1. On mobile 1 (Xiaomi Redmi), I connected the gamepad it was not working. I found that the gamepad works only with applications that request USB permission. So I installed an app that asks for USB permission, and it worked. I installed a game, cast the screen on the TV and everything was working fine. After a few seconds, it stopped working. And now it is not connecting anymore. Before connecting, I tried to read an SD card through a USB port and it was working fine. Now even that is not working.

  2. On mobile 2 (another version of Xiaomi Redmi), it shows that the gamepad is connected as the light is not blinking but always on. But nothing works.

  3. On mobile 3 (OnePlus), did a few attempts, but it didn't work. But then it started working automatically. Without giving any additional permission. Probably it was trying to download some driver in the background, no idea.

Additional info

  1. USB tethering is disabled. It says the USB is not connected. But if I connect the data cable with a laptop then it's connected.

How can I debug or fix this issue on Xiaomi mobiles?

Update It seems weird. But when mobile battery is less than 15% then it automatically connects.

  • What's the gamepad model? Does this happen for all gamepads or just one? Does it still time out with a Bluetooth-connected gamepad? Based on the description I'd guess this is a problem on the device's side.
    – nondebug
    Jun 27, 2022 at 18:46
  • It is happening with all devices like USB, microsd card through OTG, gamepad, c port headphones. Etc. Ideally OTG option should be developer option, I believe. But not in my case. Jun 28, 2022 at 14:29


You must log in to answer this question.

Browse other questions tagged .