2

Using a current version of JuiceSSH on Android, I'm trying to set up a New Connection to my system at fe80::f9cd::4687::90cd::5da2. I've confirmed that I can ssh to that address from a Windows machine. But when I try to save the connection in JuiceSSH it tells me "Invalid Address". (I tried single colons too, no improvement. I haven't tried no colons yet.)

In case it matters, I'm using an Identity which has the same Private Key that I used from Windows, pasted into JuiceSSH as multiple lines between -----BEGIN OPENSSH PRIVATE KEY----- and -----END OPENSSH PRIVATE KEY----- lines, which seemed to be what JuiceSSH wanted to see (?). It's an ed25519 key, which JuiceSSH claims it supports; I'm not sure whether that's supposed to be indicated explicitly somewhere. But I wouldn't expect wrong key to cause an "Invalid Address" message.

I presume I'm missing something obvious. Any ideas on what would be welcome.

(BTW, I'm perfectly willing to try other Android SSH clients, but Juice seemed to be the most commonly recommended.)

2
  • Contact the author and ask why IPv6 addresses are not accepted. sonelli.com/contact
    – Robert
    Commented Jun 30, 2022 at 7:04
  • Tried that; silence so far. I was hoping that someone else who had used this successfully could describe how they made it work -- peer support in absence of author support.
    – keshlam
    Commented Jul 1, 2022 at 0:39

1 Answer 1

0

fe80::f9cd::4687::90cd::5da2 is technically not a valid IPv6 address. IPv6 address components are separated by single colons, except that a single run of all zeros can be represented by ::, which is permitted only once. It's so that something like this:

fe80:0000:0000:0000:0000:0000:0000:0001

can be more easily typed as this:

fe80::1

I understand that the invalid address worked for you in some places. Software is free to take invalid input and try to figure out what you meant. That does not mean other all software will interpret it the same way.

Using JuiceSSH 3.2.2 on Android 13 on a Pixel 6, I was able to enter a bare IPv6 address (using single colons), and it worked for me.

Double-check your entry to make sure you really did remove all the double-colons. All it takes is one stray and it will reject the address. Also make sure they were all keyed as colons (:) and not semicolons (;) -- on my phone, at least, they are nearly indistinguishable.

2
  • 1
    Ah. Different software is displaying these differently as well as accepting them differently I'll give that a spin. Tnx!
    – keshlam
    Commented Jan 4, 2023 at 17:38
  • @keshlam - Do let us know what you find. I'm curious if Juice behaves differently on different devices/builds/etc.
    – Ben Scott
    Commented Jan 5, 2023 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .