2

I'm currently trying to get Genymotion up and running. I'm installing an app which requires ARM. I'm running Android 10.0 (Samsung Galaxy S10), and for the life of me, I can't find an image for Android 10.0.

I've found images for Android 8.x and below, but I believe that the images aren't compatible with the newest version.

I just need a zip image of an ARM Translation tool for Genymotion Android v10.

0

2 Answers 2

2

Genymotion is the wrong emulator. It bases on VirtualBox and thus can not emulate a different CPU, it can only pass through the CPU, so you are limited to x86/x86_64 if if you have an Intel/AMD CPU.

For older Android versions there seems to exist an extension that allows to run 32bit ARM (ARMv7) apps on Genymotion emulator but that tool was never officially supported and there are no releases for Android 10 and higher.

The only emulator I know that can run ARM on x86 is the one shipped with Android Studio/Android SDK. Use an ARM based image (will be a bit slow) or a Google x86 image (the latter images contains an internal ARM emulation layer).

5
  • You can add images to the Genymotion player and get it working. I did it on a previous PC with an older version of android. I've also used Android Studios emulator and got the same error on the Pixel 5. I just want the version of this image for Android 10.0. Jul 2, 2022 at 16:33
  • @DawoodSulaimanSyed Yes you can add images but all images are x86 based without the capability to run ARM apps. The mentioned capability to run ARM apps on an x86 images is as far as I know only implemented in the Google x86 images for Android emulator. And to my knowledge it is not possible to run such an image on Genymotion.
    – Robert
    Jul 2, 2022 at 16:35
  • github.com/m9rco/Genymotion_ARM_Translation I want this but for Android Version 10 Jul 2, 2022 at 16:36
  • @DawoodSulaimanSyed you can follow issue #18 on the GitHub repo: Android 10 support needed
    – Andrew T.
    Jul 2, 2022 at 16:38
  • @Robert I've seen that issue but wanted to further investigate too see if I could find anything. Since there, so far, isn't such a thing, I'll just go back to Android 8 Jul 2, 2022 at 16:41
1

You can try Android 11

https://github.com/niizam/Genymotion_A11_libhoudini

It's worked for me

1
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – Chenmunka
    Mar 4, 2023 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .