0

My previous Lenovo tablet with Android 7 had no problem with this procedure:

  1. I connect it via a USB cable to a PC with Windows 7.
  2. I select the device (tablet) in the Windows Explorer.
  3. I open the (virtual) folder “Internal shared storage” (or the other, “SD Card”, as I had the SD card inserted in it, too).

Then I sow directories and files on the tablet, and I was able to copy them from tablet to PC and vice versa, rename them, delete them, and so on.

In my new tablet Lenovo with Android 11 and the same PC with Windows 7, I am able to perform only first 2 steps – then I see only an empty window, no folders in it (i.e., no “Internal shared storage” or other directory / file in it).

When I try to copy a file to that empty folder, I obtain the message as

It is not possible to copy the item.
The device stopped to respond, or is disconnected.

Is it something bad with settings? Is it possible to fix it?

Note:

I may go around and copy files from the tablet to the USB stick and then from the USB stick to the PC, but this is so annoying and slow…

(The USB stick is connected with a short converting cable to the same USB port on the tablet as the USB cable connecting the tablet and PC in the previous step 1.)

3
  • I would try a different USB cable. The error message you got indicates a hardware problem.
    – Robert
    Commented Jul 10, 2022 at 18:20
  • @Robert, thanks, do you mean the problem may be still in the cable, in spite of the same cable is still OK with my previous tablet?
    – MarianD
    Commented Jul 10, 2022 at 18:48
  • 2
    I miss a step after 2 and before 3: "confirm access on the Android device". Not sure with which Android version that started, but when I connect an Android-11 device here (to my Linux machine) I also get an empty folder – until I confirm the PC is allowed to access the device.
    – Izzy
    Commented Jul 10, 2022 at 23:00

1 Answer 1

1

Android 11 default behavior after connecting to the other device via a USB cable is

  • No data transfer

(In the non-developer mode, there are no settings for changing this safe default behavior.)

It means, you have to change it again and again after every connection.


So, after every connection, you may follow (for example) these steps:

  • If you don't see notifications, swipe from the top of the screen to open them.
    (If needed, scroll notifications up until you will see the section title “Silent”.)

  • Beside other notifications you will see the text

    Android System - Charging this device via USB                                ᐯ

  • Tap on the down-arrow symbol to the right of this text to open the menu. You will see something as

    enter image description here

  • Following the instruction under the (already displayed) text, tap for more options.

  • You will be redirected to the “USB Preferences” in the “Settings” screen, where you may select the option “File Transfer”:

    enter image description here


Note:

If you have enabled Developer options (see Enable developer options), then you may change the default behavior:

  • In the Settings select System → Developer options.

  • locate the Default USB configuration and tap on it:

    enter image description here

After it, you will see similar options as in the previous picture, and you can select File Transfer to automatically select this mode after every connection via a USB cable.

But note that it is not safe for connecting to unknown devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .