0

tl;dr: Is there a way to check that my phone is aware of the existence of my 3.5 mm aux port?

I have a Blackview BV4900 Pro running Lineage 19-20220613-UNOFFICIAL-arm64_bvS, and nothing happens (= the sound is still played through the speakers) when I insert a headphone cable in the 3.5mm audio jack slot.

I have:

  • Checked that the jack slot used to work with the original Rom,
  • Tried the headphones on a different device,
  • Tried different headphones on the same device,
  • Disabled AudioFX,
  • Disabled bluetooth,
  • Checked the audio settings,
  • Restarted the device,
  • Checked that the slot was not dirty.

How do I try and understand what is wrong?

I have tried adb shell dumpsys | grep headset to see if there is anything related to my issue, but could not find anything relevant.

5
  • Did you report to ROM developer? Or search in the ROM discussion forums?
    – beeshyams
    Jul 14 at 5:46
  • 1. I have not, the rom is "unofficial" and supports (more or less correctly) a wide range of devices. 2. Yes, with no luck. My question could be better rephrased as "Is there a way to check that my phone recognize my jack port"?
    – Clément
    Jul 14 at 15:53
  • IDK if there is a way now but this old answer says there isn't// download this app and under tests, run the audio test. On my phone it plays music through speakers and through earphones when I plug them in// If it doesn't, it's either a ROM issue or hardware issue, since you indicate that there isn't a problem with the headphones
    – beeshyams
    Jul 14 at 16:47
  • Probably obvious, but did it ever work even before flashing LineageOS? P.S. Andy Yan is one of our users here.
    – Andrew T.
    Jul 15 at 16:06
  • It did, thanks for checking out.
    – Clément
    Jul 16 at 11:00

0

You must log in to answer this question.

Browse other questions tagged .