I purchased a USB C thumb drive to make transferring images off my phone (Samsung Galaxy S10) a little simpler. However, upon being prompted for the "Charging Connected Device Via USB" for "USB Settings", USB is controlled by "Connected Device" instead of "This Device". I still went into my developer options and changed the "Use USB For" default so I can "transfer files/Android Auto". However, I still can't successfully change "USB Controlled by".

It prompts me to "Restart Your Phone", stating "a USB storage device was removed unsafely. To prevent your phone from restarting unexpectedly, save unsaved data and restart now"... but it won't allow me to switch, and restarting has no effect.

This USB only does this when attached to my phone - my computer doesn't have the same issue. Formatting the USB had no effect, and I couldn't find any saved connection in my phone to delete to see if it would forget this setting.

I have tried looking into this issue and I can't find any help online.

How to reverse the USB controller so that the thumb drive is controlled by "This Device" instead?

  • 1
    How large is the USB stick and what file-system have you used for formatting?
    – Robert
    Jul 15, 2022 at 16:05
  • I tried to clarify the title to summarize the issue. However, if it's not correct, feel free to edit and revise it further. Thanks
    – Andrew T.
    Jul 15, 2022 at 16:39


You must log in to answer this question.

Browse other questions tagged .