I flashed Pixel Expirience GSI with TWRP by pushing it to the storage and flashing it as system img(with TWRP).
The problem, it’s now stuck in a Google animation which came after the Sony logo.
I would like to shut it down.
I already tried

adb reboot but
error: device unauthorized

And pressed the power off button 1 min and nothing happened.
I tried to install some GSIs, but they were stuck at the costum Romes Loading animation.

  1. I installed the Firmware with Emma
  2. Locked it to update to Android 11 and unlocked it again
  3. Installed TWRP and booted into it
  4. Wiped system and userdata
  5. Pushed to system.img file from the custom rom to my device into /sideload/
  6. In TWRP install-System Image—> Pressed on the folder and on the system.img
  7. It installed successfully
  8. Rebooted
  9. Stuck in Loading animation\

(PixelExpirience == A Google G with loading bar, LineageOs == The blue line with the bubble)\

No crashes or so what, it just hangs in there for ~20 min and than I turn the device off with volume(+) and Power button.\

I know Sony Xperia 1 is not officially supported for project treble, but since this thread(https://forum.xda-developers.com/t/mars_soms-v220313-pixel-expierence-android-12-gsi-patches.4097433/) requires Pixel Experience GSI I thought it should be possible to run GSI on Sony Xperia 1.
Any idea what I might have donne wrong or are there other GSI roms I could try.\

PixelEX = PixelExperience_Plus_arm64-ab-12.1-20220613-UNOFFICIAL.img 3.7 GB
LineageOS = lineage-19.1-20220613-UNOFFICIAL-arm64_bvS.img 2.0 GB

2 Answers 2


I was able to power it down again by pressing Volume(+) and Power button 5sec


I final solved it. Sony Xperia 1 Exactly what I did:

Installing stock firmware, will be different from device to device

  1. Power the device off
  2. Plug it in while holding Volume(-) until a green light appeared.
  3. Open Emma(Sony Xperia Firmaware flash Application)
  4. Flashed Android 9
  5. Boot until I got to the welcome screen( just to check if the Firmware flashed successfully

Installing the important Files

  1. When there https://developer.android.com/topic/generic-system-image/releases
  2. Downloaded the right files for my device (Arm64)
  3. Unzipped it —> system.img and vbmeta.img

Installing the files

  1. Powered my device off and booted into fastboot
  2. went to the download directory and
    I don’t know why but these two commands, error the first two times when I tip them. Important(when the command errors, press the fast boot button, because my device at leased, tried to escape into a green light mode, but just because it switches to the green light mode does not mean that you should stop it, only if it errors and wants to go into the green light mode.) \

fastboot flash system_a system.img
fastboot flash system_b system.img
fastboot --disable-verity --disable-verification flash vbmeta_a vbmeta.img
fastboot --disable-verity --disable-verification flash vbmeta_a vbmeta.img
3. Wipe the phone
fastboot -w
4. Restart
This worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .