1

I noticed, whenever I am in foreign country (i.e. DATA ROAMING) I can connect other devices to my android phones via its hotspot, but they (devices) have restricted access to internet.. In other words: My phone, where I would like to share internet via operator's data in foreing country roaming DOES have internet access, but devices connected to it via WiFi hot spot do NOT. As soon as I return to home country, the problem disapears and tethering works normally. This I've noticed on 2 Android phones I owned and tried: Nokia 6.1 and Motorola G10.

Vendors claim they do not have a fix for it, operator also claims he is innocent. Does it look more like a problem of Andorid OS, foreign operators, or my home operator ?

Edit: (based on Robert's suggestion)

My home country: Slovakia (Not to be confused with Slovenia)

My home operator: 4ka

Foreing countries traveled: Austria, Czech Republic, Germany, Netherland, Belgium, France, Luxemburg

Foreign operators: Any one I encountered. Really do not know their names.

Can anyone help to identify the source of the problem, please ?

3
  • I have the same problem with operator 4ka. I have checked hotspot in roaming: Czechia, Poland. I checked it on many modern Samsung phones (more than 3) and no internet on hotspot connected devices. The strange thing is that it works on a very old Samsung Note 3. I'm really curious what that? If I good remember it was working before (2020).
    – user389120
    Apr 18, 2023 at 11:49
  • @user389120 Well, so this looks pretty much like a problem of the rookie operator 4ka :)
    – Peter
    Apr 18, 2023 at 14:56
  • @user389120 I am expecting the same issue with 4ka operator. Data roaming is working on multiple devices with different os (as Android so iOS) but the internet via hotspot in data roaming is NOT working. My susspissios is (while reading these comments and considering my experience) that this is 4ka issue.
    – AndrejHan
    Dec 11, 2023 at 23:26

2 Answers 2

1

Solution found!

TL;DR: Add default,supl,dun to the APN type field in your APN.

Long story:

I was experiencing the same problem with the 4ka operator (see my previous comment).

After a few hours of debugging, reading, and multiple try-error tests with several options in APN settings, I am able to access the internet on my Mac laptop via a Wi-Fi hotspot from my Android phone (OnePlus 8T) while I am roaming.

Evidence can be found here:

Printscreen showing active data consumption

All setting of the APN used are here:

APN settings - 1st part APN settings - 2nd part APN settings - 3rd part

I hope it helps! :)

1

Recently operator 4ka started to distribute warning sms after a mobile station crosses country borders. In essence it gives the message: "For proper functioning of your internet access, please set your APN NAME to 'internet'"

So I did and interestingly enough it DID help !

Hence, there is a good chance they have likely started to investigate after many complaints of annoyed clients and automatically distribute this sms. Can't believe it took +-5 years to fix this problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .