I embarked on a planned factory reset and hence started the procedure with a Nandroid backup (via TWRP) of all available partitions.

Following the reset, after restoring the data partition from the backup, the boot sequence gets stuck on "Phone is starting...". After five minutes (or so) the phone restarts and then says:

Cannot load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data store on this device.

...providing the option to "Try again" or "Factory data reset".

Restoring any other partition from the Nandroid backup produces no issues, it's only when the data partition (the most important to me) is restored does this issue occur.

The backup is not corrupted, as the digest verification succeeds.

Do I have any other options other than:

  1. Discard the backup and start from a blank slate.
  2. Start from a blank slate and manually extract the most important data from the data partition.


Ideally I'd like to be able to diagnose the root cause of the "Phone is starting..." issue, address it and continue to use my phone as it was prior to the first factory reset. I have done this restore process successfully before, but this time it's just not working for me.

  • Phone: Fairphone 3+
  • OS: Stock
  • Bootloader: Unlocked

Restoration procedure I do (following a factory data reset):

  1. Boot phone.
  2. Follow prompts to set same screen lock as prior to reset.
  3. Restart phone into fastboot mode.
  4. Boot into TWRP (using screen lock credentials to decrypt data partition).
  5. Restore from backup.

2 Answers 2


The following procedure worked for me:

  1. Factory reset data partition. If you can't boot, this can be achieved by running fastboot flashing lock, and then fastboot flashing unlock (because locking/unlocking the bootloader results in a factory reset).
  2. Boot into the operating system and follow the setup prompts, ensuring that no screen lock is set!
  3. Turn off phone.
  4. Boot into TWRP.
  5. Restore just "data" partition.
  6. Reboot.
  7. Re-enable screen lock as desired.

Sometimes, bypassing screen unlock (as per one of the answers) isn't enough. Need to actually Format Data in TWRP.

Some recoveries can't deal with FBE and so you'd have to Format Data and disable FBE and then take a TWRP backup of that. Your ROM will basically be decrypted at that point. When you then do a restore, it'll work fine.

I've had this issue today, tried all sorts of things, ended up going with the above as a proper working solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .