I have an Android 11 box (Android TV Box 11.0, 4GB 64GB Decodificador Android Box, Amlogic S905W2 Smart TV Box"), and am trying Retroarch.

For controller 1, I have a Power A Liquid Metal XBox One controller. Works fine so far.

But no matter what I configure as Input 2, the 2nd controller stills controls player 1.

I tried several controllers for Input 2, and it's always the same thing. I tried a Wired Rock Candy Switch controller, BlueTooth Atgames Legends Mini, and I also tried using a second Power A Liquid metal Xbox One controller.

No matter what I do, it seems to think that both controllers are the same controller. (both control player 1).

What I noticed that's weird is that since it thinks both controllers are the same, and I mapped both Input 1 and Input 2 to it, when I'm in certain menu screens, when I hit down, it registers twice. I'm guessing because it thinks both players hit down.

I tried both SNES9x and Final Burn Neo. The problem seems to be at the Android level (before getting to Retroarch).

Is it normal to have an Android 11 device only accept one controller? Or is it possible that it's a problem with my device specifically?

  • Update. I tried connecting a new controller via Bluetooth: Ipega 9087s. Same problem. But one thing I just noticed is that in Retroarch, when I set the inputs, it lists both controller's "device index" as "virtual". It shows "Virtual" for both controllers. This does not happen when I use Retroarch in my FireHD10 tablet. Same controller, the "Device Index" actually shows the name of the controller (Ipega 9087). Is this a clue?
    – NL3294
    Aug 9, 2022 at 18:28

1 Answer 1


This is the bug [Android 11 DP/Beta] Bluetooth Gamepads Aren't Reported as Source of Input Events".

A workaround is described in a reddit post by /u/SuttonX:


If you don't want to get Tasker, you could just manually go in to your phone settings and turn off all your Accessibility Services permanently.

  • Thank you! I was starting to think my device had a defect! I just wanted to note, in that bug report, the person wrote "Bluetooth gamepads", but it turns out to also affect USB gamepads. Thanks again, this was driving me nuts!
    – NL3294
    Aug 10, 2022 at 21:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .