1

I was trying to flash TWRP onto my Android tablet (Lenovo TB-X306F), but something went wrong and it failed. Now, every time I boot, no matter what I do (sending adb commands or pressing physical buttons), it goes to the (now broken) recovery.

I'd like to know if there's a way to forcibly boot into the bootloader so I can use fastboot and flash the stock recovery (I have the original images for everything).
I tried flashing it using flash_image recovery /path/to/recovery.img through adb shell (which is accessible within that "zombie" recovery), but it failed with: failed with error: -1. I've looked up online and couldn't find the meaning of such error, but I suspect it's related to trying to flash the recovery while being in the recovery?

Thank you in advance.

4
  • One thing I just noticed though: the tablet is in fact the X306F (shown in Android's system info and it corresponds to the Lenovo M10 HD I bought on the store), but in adb's shell, the prompt is X606FA:/ #. According to some XDA threads I saw, the 606 series corresponds to the M10 Plus models. Not sure what's going on here.
    – Tmpod
    Aug 11 at 9:36
  • adb reboot bootloader
    – alecxs
    Aug 12 at 12:58
  • > no matter what I do (sending adb commands
    – Tmpod
    Aug 12 at 23:34
  • Does this answer your question? adb device doesn't listed on cmd {Lenovo K8 Plus}
    – alecxs
    Aug 13 at 3:14

1 Answer 1

2

I finally solved this conundrum!

After digging around a bit more, I found this blog post on someone's website (thank you!) and tried it out. In my case, I had /dev/block/platform/bootdevice/by-name/recovery but it still worked wonders.

In case that blog ever goes down, what you have to do is check that path and see if it matches. Like the post suggests, you can do DEV=$(ls /dev/block/platform/*/by-name/recovery); echo $DEV.
Then, it's a matter of using dd to dump the image onto that path, like this: dd of=$DEV if=/path/to/recovery.img (I put mine in /sdcard with adb push).
Finally, just reboot using adb reboot ... or using your device's physical buttons.

Hope this helps!

4
  • How does this "Force boot to bootloader"? your answer is about flashing stock recovery from shell, which seems unrelated to question
    – alecxs
    Aug 12 at 12:54
  • Well, yeah, looking back at it, it certainly sounds contradictory, but the issue was in fact the broken recovery which seemed to "trap" the boot sequence. I couldn't boot to anything with adb, fastboot or physical buttons whilst in that broken recovery and a normal reboot would always get me stuck on the recovery again. AFAIK the boot sequence is bootloader -> recovery -> system, so it repeatedly got locked in that second step. Flashing the proper recovery by hand like that allowed me to break this cycle and get proper access to the bootloader again. Thus, it solved my issue.
    – Tmpod
    Aug 12 at 23:34
  • if TWRP would be broken, you wouldn't be able to use it. there is no trap, system was sending into recovery after unsuccessful boot
    – alecxs
    Aug 13 at 3:11
  • As you can see in this XDA thread, TWRP seemed to be very much broken.
    – Tmpod
    Aug 16 at 13:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .