0

I followed these steps (in brief, enable debugging and use adb to enable storage and format sd card) to enable adoptable storage on a Samsung A01 to make the phone more usable (device is not rooted). It basically seemed to work and some apps could be moved to the SD-card and freed up space.

It freed up enough space that I then tried to update the OS (to One UI 3.1 / Android 11) and am now stuck. After the install, most software just hung until I removed the sd card. I have since reformatted the card and uninstalled all the apps previously moved to it and tried the same command sequence hoping to re-enable adoptable storage.

The phone basically works now except the SD card isn't working correctly - I assume it's still looking for the now missing adoptable storage. It complains: "SD card missing" / "insert device again".

I'm wondering if there are similar adb commands to undo adoptable storage - even if the adoptable storage partition is missing. Hoping to avoid a factory reset.

Thanks for any tips!

1 Answer 1

2

I came back to this and found the magic incantation here:

Basically, connect back to the device and redo the earlier partition command replacing the word "private" with "public". In my case:

adb shell sm partition disk:179,64 public

Having said that - I then tried to redo the process and am discovering the phone may not play well with adoptable storage. Wonder how many phones get landfilled because of this design issue - all of 2yo.

Perhaps I spoke a bit too soon... Wasted a couple more hours on this and found another nugget on reddit: buried in Developer Options is "force allow apps on external" With that I was finally able to free some storage and it seems to work - time will tell. Perhaps leaving this here may be of use to someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .