1

When I restart my Samsung Galaxy S9, the screen timeout value changes to "()".

Notice that's not a zero; it's two parentheses. That's literally what appears in the settings. However, the phone must think of it as a zero, because the screen goes dark immediately when I'm not touching it (and then I have to enter my password again).

This setting change also happens if I have the Power Mode in "Maximum Power Saving" and I switch to a different Power Mode. I don't think it happens in Safe Mode.

This started happening a few months ago. It also happened with my old Galaxy S7; my solution was to get the S9. (JK, I had other reasons too.)

EDIT: Yes, Cody: I can set the timeout to any value, but when the phone restarts or comes out of "Maximum Power Saving", the timeout is reset to "()".

4
  • Do you use this phone with a work profile linked to your company? If so, it may be a security attempt to defeat non-privileged users. The immediate lock is drastic. If unsure, check for device administrators that are running you may not be familiar with.
    – wbogacz
    Sep 21 at 23:05
  • Possibly similar case (Samsung Galaxy Note 2, 2013): Android Central Forum - Screen timeout disables itself?
    – Andrew T.
    Sep 22 at 1:54
  • @AndrewT. That's not a similar case -- it's the same case! It doesn't explain the issue, but I guess Stay Awake might be a good workaround. Sep 22 at 17:56
  • @wbogacz I did have a work profile. I went to Settings --> Apps --> Special Access. Under "Device Admin Apps", nothing was active. I thought it might be under "Optimize battery usage", but there are hundreds of system-related apps; turning off "Work Profile" and "Work Setup" didn't work and I don't know where to start with all the others. Will try "Change system Settings" next Sep 22 at 18:20

2 Answers 2

2

Following @wbogacz's lead, I went to Settings --> Apps --> Special Access --> Change system Settings. I discovered that Avast Battery Saver had control over the timeout, so I revoked that privilege. (I think I could also have done it in the Avast app itself.)

That solved it.

0

So, when you have set the timeout to be a longer length of time you see this issue? I assume you have tried rebooting your phone and trying software updates. If all else fails, you could try resetting the phone.

2
  • Let's try to diagnose and correct the problem short of nuking it right away, eh?
    – wbogacz
    Sep 21 at 23:08
  • Yes, @cody-b, that's what happen, and I've rebooted it many times. The software is up to date. Sep 22 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .