I've recently broken the screen of my Samsung Galaxy S7 (model number: SM-G390F). USB debugging should be enabled, however MTP seems to be disabled as data cables (work for file transfer with other phones but not for this one) are able to charge it (vibrates when plugged in), but neither the file explorer nor the adb list of devices features it.

Are there any way to force the recognition, to get around it not being detected, to mirror the screen or use a different output, to check if the touch is still active or both screen and touch are broken? To figure out where one would need to do blind presses to enable the necessary permissions?

So far I've tested several cables and are in possession of data micro-USB cables for data transfer, I tried to access it via adb and failed, I tried to do this power, home, vol up or down, but I don't see a result with screen broken. I've read several post on this topic but they are either outdated or weren't successful. Are there any options that come to mind on how to access and recover the data on the phone?

Edit: The only response left from the screen is that the pseudobuttons left and right from the home button light up when I press the home or power button. Also the light in the top left is occassionally blue or red (when charging). Attempts to take screenshots on an sd card (unfortunately only inserted after the screen stopped working) have not been successful, though that could just be a me issue and not a phone issue, I'll keep trying later).

  • 1
    Does your phone has a pin/password/pattern? MTP usually does not work when the phone is in locked state (lock screen is shown). So you have to first enter your PIN/password using an USB keyboard. Also adb access may be limited before the first time you have entered lock screen password, because after reboot most user files are still encrypted and thus not accessible.
    – Robert
    Commented Sep 25, 2022 at 10:29
  • Good point. Since I removed the sim card there should only be a swiping pattern left to guard it (I still know that pattern). It might be difficult but possible to apply that. Though so far I haven't gotten positive or negative feedback from trying that. Also while detecting the cable and loading is possible when plugged in and never touching it, the cable was never particularly well adjusted in the socket, switched to induction loading because of that, so might take a few attempts for that as well. So far I wasn't particularly successful with that, but thanks very much for the tip.
    – haxor789
    Commented Sep 25, 2022 at 10:44

1 Answer 1


I would recommend trying to mirror its screen, for if its only the internal screen then it should have no problem giving an output. Then, if the touch screen still works. Either check settings, Get a new screen, Or try factory reset

See HERE for MicroUSB to HDMI adapter

  • I checked my local electronics shop and they argued that micro-usb and normal usb have no video out. Then I checked the internet and found that to be bullshit. However there are differences and apparently the phone needs to support Mobile High-Definition Link (MHL) and as far as I can find the Galaxy S7 did no longer support that, thought accounts may vary.
    – haxor789
    Commented Oct 4, 2022 at 8:35
  • Would it be possible for you to get the model number? Commented Oct 4, 2022 at 15:32
  • Probably no I don't have the manual ready and I can't access the phones menu. Is there a way to tell from specs or exterior?
    – haxor789
    Commented Oct 4, 2022 at 17:15
  • Well... I mean you could get a couple of useful bits of information from cracking the phone open (personally i have a phone which just pops off. Commented Oct 5, 2022 at 19:17
  • The S7 is not among those that can be easily opened without tools and damages (at least not as far as I am aware off) but apparently the model number is listed on the case it seems to be SM-G390F
    – haxor789
    Commented Oct 5, 2022 at 20:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .