2

I love PDAnet for android, works great on my Windows machine. Unfortunately, I just found out (after installing Ubuntuon my HP mini) that there's no Linux client. Can anyone recommend a tethering app, non-root, with a Linux/Ubuntu client?

  • 1
    What Android version are you running? Froyo 2.2 already has wireless tethering so that should do it for you otherwise can you upgrade to 2.2? – mlevit Oct 29 '10 at 0:18
  • 2.2: Verizon doesn't allow wifi tethering on Droid 1 to my knowledge (without paying more ) @mlev – mfg Oct 29 '10 at 2:24
  • So they modify the actual OS to disable that feature do they? Go to Settings > Wireless & networks > Portable Wi-Fi hotspot Can you enable it? Does it even exist on your phone? – mlevit Oct 29 '10 at 3:14
  • @mlev it's sad,they ripped it right out. – mfg Oct 29 '10 at 11:06
1

Try AziLink (http://code.google.com/p/azilink/). You will need to do a little setup on your Ubuntu machine in addition to loading the app on your DROID, but it will work without requiring you to root your DROID. This is a USB tethering solution that I have used in the past with my Ubuntu netbook to great success.

| improve this answer | |
0

I used this modified version of Proxoid for quite a while.

You need to set up the android developer kit first, and follow the instructions on the Proxoid website on how to enable it.

| improve this answer | |
0

Recycling an answer from a recent duplicate.


Easy Tether from Mobile Stream should work. It's a way to share your internet connection with another device via USB. Get the Lite version (does not support https, or tethering to gaming consoles) or the Full version.

Supports Windows 7/Vista/XP (32-bit and 64-bit), Mac OS X 10.7/10.6/10.5/10.4, Ubuntu 10.4+ and Fedora 13+

Full version supports the following:

Tether PS3, Wii, XBox via PC Internet Connection Sharing, you need a computer for game console tethering.

| improve this answer | |
0

Just a mention I have AziLink working to tether both Puppy Linux (dpupbuster64) and Lubuntu 19.04 to an older Sonim XP5 phone. I use a reseller MVNO on ATT network. They have no problem with customers on GSMA network (ATT) tethering, but the phone I am using is network locked to ATT and ATT had hotspot and tethering locked to try and charge more. Try to use the built in hotspot/tethering and get popup to call ATT. I tried rooting with no success, but the free crippled EasyTether and open source free AziLink worked. AziLink took little more work to set up and it seems abandoned, least no mention of it since like 2011 (Its 2020 now). So saved myself $10 over uncrippled EasyTether and learned something in setting AziLink up.

I am just posting that AziLink still works in 2020. It will occasionally go into a connect-disconnect loop, rare but happens. You just reboot your computer, make sure service is on in AziLink app on phone, then run the commands (I use a script with shortcut on desktop to make it one click). I think openvpn is the cause of this, so killall openvpn might work too. Havent tried that though. Remember AziLink was made for version openvpn from ten years ago and AziLink hasnt been updated. I am using current version openvpn so...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.