2

The screen of my phone broke some months ago, but luckily I had already enabled USB debugging and I trusted my PC, so I could use the phone with a USB with Vysor (a free open-source app) and I've been using it like that for months.

I was casually using the phone and I just changed it to MTP mode (I clicked the just once button so I could use the phone again, it's not the first time I do it and it went back to normal before) but now every single time I plug it in, it goes straight to MTP instead of charge only as it should be.

I tried resetting the phone by taking the battery off and putting it in again, no success.

Things that may be useful to know:

  • The volume button doesn't work at all
  • It's an LG K10 M250 without root, Android 7
  • I tried 3 different USBs and it's the same story
  • It's hopeless to touch the screen, saying it again just in case
  • ADB Drivers are installed, Dr.Fone and EaseUS recovery apps tell me that debug is disabled even though I know that it's enabled.
  • I won't fix the screen of this phone, the fix's worth another phone, which would be silly.

I googled a bunch and the results only show people with debugging disabled and/or MTP disabled, I have the exact opposite case, and I do need the phone to use banking apps and things like that, I would appreciate it if people want to suggest stuff I could do, my brain thinks that there should be a trick since the phone is connected after all.

I found the drivers on the device manager, it straight up says that it isn't connected. I disabled MTP Automount on Linux udev configuration and now a pop-up says "Unable to open MTP device "001,009""

Vysor screenshot

ADB driver

Linux terminal lsusb

13
  • Default USB mode can be set on a lot of devices in devoper menu.
    – Robert
    Commented Oct 1, 2022 at 22:50
  • @Robert "broken screen" and, according to the description, device not detected by ADB – so how to reach the developer menu?
    – Izzy
    Commented Oct 2, 2022 at 0:03
  • @Izzy as mentioned in the question Vysor allows UI access. MTP and adb access can be active at the same time so this should still be possible.
    – Robert
    Commented Oct 2, 2022 at 7:57
  • well, that's the problem, i cant access to my phone UI with vysor to disable mtp, and adb access seems to not work with MTP on, i'll try my luck installing a custom adb driver with a modified .inf that allows both to be active at the same time
    – ReddaZ
    Commented Oct 2, 2022 at 13:52
  • update, i'm trying to use vysor on linux but it doesn't find the device and it still straight up goes to MTP, tho i may be able to do stuff in linux that i cant on windows, but idk what those things are
    – ReddaZ
    Commented Oct 2, 2022 at 17:04

0

You must log in to answer this question.

Browse other questions tagged .