Is there a working root for the myTouch 4G Slide?

I have Android 2.3.4.

I tried Revolutionary as advised by rootzwiki, which failed with the following message.

Your device: doubleshot, with HBOOT 1.45.0013 is not supported at this time

I tried SuperOneClick, which failed.

None of the other methods I saw on the How do I root my device page appeared to support my version of Android. Is there perhaps some method where I could downgrade, or is there some other new method out there?

Edit: My bootloader is unlocked with the tool from HTC

3 Answers 3


Since you've already unlocked your bootloader, you should be able to flash a recovery from fastboot and then use that to root. This will get you root on your stock ROM (but not S-OFF):

  1. Download ClockworkMod recovery for the doubleshot from this link
  2. Download the Superuser/su zip file from this link
  3. Reboot into fastboot mode. To do this, remove power off the phone, remove the battery, then hold volume down while you re-insert the battery and press power. When the bootloader menu appears, press power again to select "Fastboot".
  4. Flash the custom recovery image: fastboot flash recovery /path/to/clockworkmod.img.
  5. Reboot into recovery (reboot and hold volume down, I believe, otherwise use #3 above to boot into the bootloader then press volume down to select "Recovery" and press the power button).
  6. Copy the Superuser/su zip file onto your device and install it from recovery. It may be easier to get the zip onto your device if you first reboot normally and then use Android's mass storage feature to just copy it over.

What you are attempting to do is not rooting, it's called S-OFF. S-OFF is a level below root. Root is like being the administrator on a Windows machine, whereas S-OFF is like having permission to modify values in the BIOS. It's complete control. S-OFF might not be what you need for what you want to do if all you want to do is root your stock ROM.

  • I've read about s-off, I understand that it allows you to install custom radios, which I don't think I need. Really, I'd just like to load a custom rom, but the methods I've tried seem to require root, which I haven't been able to get.
    – axiomx11
    Commented Jun 27, 2012 at 12:08

One question: Is your bootloader unlocked? If not that's why Revolutionary failed.

If your bootloader is locked, you need to use the HTC's unlock bootloader found here, then re-try using the Revolutionary root.

The clue was in the message which with a bit of google-fu yielded this thread on xda, post #214 and post #215 (you will have to go back to page 22 on that said thread).

I am not responsible for any outcome by my posting this answer.

Read and re-read and make sure you are ready to go ahead and do so.

  • Yes, I have already unlocked my bootloader with the official HTC tool. It looked like it worked, but I'm still getting the same message from Revolutionary.
    – axiomx11
    Commented Jun 27, 2012 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .