I came across this weird issue and wanted to share my findings somewhere.

At some point in the installation process of Magisk, I was required to use fastboot on Windows 10 21H2. I proceeded and downloaded the adb plattform-tools + adb drivers. Previously ADB-related things of the instruction (like adb-shell) worked flawlessly.

However during the usage of fastboot I encountered these issues:

enter image description here

I tried different USB-cables, -ports and -drivers.. When I ran fastboot devices (or any other fastboot-command, it returned ???????????? (or an error) and the device restarted..

I was pretty certain that the device itself was fine, as well as the installation of ADB tools and driver. Nothing seemed to work and I only read about solutions like using a different PC, which was no option in my opinion.

1 Answer 1


Thanks to this hint from cychau, I used a USB 2.0 hub, which showed me that it's a >USB 2.0 related issue. Another suggestion (from bitbox in #7) was to restrict the system to only use USB 2.0 through BIOS settings.

Hope this helps someone in the future :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .