2

I've downloaded Chrome 106.0.5249.79-524907934 from APKMirror and installed it (along with the corresponding Trichrome package) on a Pixel 5a via

$ unzip com.android.chrome_106.0.5249.79-524907934_8lang_11feat_..._apkmirror.com.apkm
$ adb install-multiple -r -d *.apk

So far, so good. However, when I try to start the app via

$ adb shell am start -n com.android.chrome/com.google.android.apps.chrome.Main -a android.intent.action.VIEW

I get

Error type 3
Error: Activity class {com.android.chrome/com.google.android.apps.chrome.Main} does not exist.

Running adb logcat at the same time shows

W PackageManager: Intent does not match component's intent filter: Intent { act=android.intent.action.VIEW flg=0x10000000 cmp=com.android.chrome/com.google.android.apps.chrome.Main }
W PackageManager: Access blocked: ComponentInfo{com.android.chrome/com.google.android.apps.chrome.Main}
2
  • I just tried the command on Pixel 3a, Android 12 and it succeed. Could you open Chrome manually? Otherwise, check if Chrome is disabled or not, because it returned the same error when I disabled it.
    – Andrew T.
    Commented Oct 25, 2022 at 15:30
  • I can load it manually. Commented Oct 25, 2022 at 15:32

0

You must log in to answer this question.

Browse other questions tagged .