How can I set my android x86 resolution to 1920*1080 in my VM?

I tried this:Can't change screen resolution of Android-x86_64 installed in UEFI mode

but it didn't work.

BTW I have a UEFI installation

Thank You in advance.

1 Answer 1


I solved it! These sources helped me:

  1. Boot into (DEBUG mode) from the grub menu on boot.
  2. Press enter after the boot completes(the screen stops producing text outputs)
  3. Mount your efi partition by running this command:
mount /dev/sda1 /mnt

(sdax, here x may vary for you, but for me, it was 1)

  1. Change directory to /mnt/efi/boot:
cd /mnt/efi/boot
  1. Edit android.cfg, as shown in the picture below
vi android.cfg

enter image description here

  • Inside Vi Editor

i. Press 'i' to enter edit mode

ii. Press 'Esc', type ':w', and press 'Enter' to save.

iii. Press 'Esc', type ':x', and press 'Enter' to exit.

  1. Now reboot
reboot -f

That's it, you have Android x86 in your system's native resolution!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .