At home I can use the AdGuard DNS via settings -> WiFi & network -> private DNS -> private DNS provider hostname, and setting that hostname to dns.adguard.com.

In many public places where I do have WiFi without using this DNS, using AdGuard gives the error "Private DNS server cannot be accessed" and WiFi is not used.

Specifically the EduRoam university network does not work with the AdGuard DNS.

It means I often switch back to private DNS -> automatic, but in practice that seems to work the same as private DNS -> off: even at home where the AdGuard DNS would work, it is not being used.

Does anyone know if there's another setting that would make AdGuard usable in those public places, or at least to have an "automatic" option that does at least use AdGuard when possible?

  • You are probably better off asking in the adguard forum or raising a ticket through their app//I found both to be good options though the service is slow//AFAIK there isn't any other setting
    – beeshyams
    Dec 6, 2022 at 6:46
  • For the AdGuard-specific bit I will, thanks. I find it strange though that the settings 'automatic' and 'off' are basically the same. Not sure if that is only for AdGuard.
    – alle_meije
    Dec 8, 2022 at 6:04


You must log in to answer this question.

Browse other questions tagged .