0

I have a moto g(7) power with an international T-Mobile plan that is supposed to allow me to use my phone in most countries around the world without needing to get new SIM cards. This works most of the time, but I've noticed a few countries not behaving correctly. What normally happens is that I'll get a text message from T-Mobile saying "Welcome to X country" and explaining that I have 5 gigs of high-speed data per month for that country. Then once the high-speed data runs out, I can still use unlimited low-speed data for the rest of the 30-day cycle. But for the countries where this doesn't work, I'll still get the text message that confirms the country is covered by my plan and I'll see that I have cell signal but when I open a browser or try to use messaging apps it says there's no Internet.

Here is how it worked in Australia and New Zealand for example:

  • ✅ I get a text confirming that I have coverage in the country
  • ✅ The cell signal icon indicates a strong connection
  • ✅ I am able to use mobile data

Here is how it's working in Fiji:

  • ✅ I get a text confirming that I have coverage in the country
  • ✅ The cell signal icon indicates a strong connection
  • ❌ I am not able to use mobile data

Curiously, it seems that I am able to make phone calls and use SMS in Fiji, and I guess that's because those things are considered by phone plans to be different from mobile data.

At first I thought maybe the problem was related to the 5 gigs of high-speed data being expired, but the problem still wasn't solved when the cycle ended and my high-speed data was renewed. I've tried using mobile data in Fiji both with and without high-speed data available and the problem is the same in both cases.

T-Mobile customer support didn't seem to understand the problem unfortunately. Here are the troubleshooting steps they ran me through:

  1. I reset the phone's network settings multiple times
  2. I restarted the phone multiple times
  3. I enabled international roaming

None of that worked, of course. What is causing this problem, and is there anything I can do to fix it?

5
  • 1
    Try shutting down the phone, taking the SIM out, inserting it after a minute or so and power up the phone. Logic:Your device will be re-registered on the local network (supported by your carrier) and this may help
    – beeshyams
    Dec 13, 2022 at 9:51
  • 1
    You might want to check the APN setting.
    – Andrew T.
    Dec 13, 2022 at 13:57
  • 1
    This ^^^ and/or try selecting a different network. Not all providers have roaming contract/agreement with your provider. Dec 14, 2022 at 11:15
  • I have tried your suggestions with no luck. I guess maybe T-Mobile promises that a country is covered even if there are no networks in that country they support Dec 15, 2022 at 9:34
  • Hold on, I was finally able to get it working by turning off "automatically select network." I guess T-Mobile supports Digicel and not Vodafone. Someone post that as an answer so I can accept it! Dec 15, 2022 at 21:49

0

You must log in to answer this question.

Browse other questions tagged .