3

I am trying to transfer a large amount of files (>40k images and videos). I've had trouble transferring it by dragging and dropping in Windows File Explorer so I used the adb push command. It works on the internal storage of my phone just fine. However, when I try to do it on my SD card, it just refuses to start. It would be stuck at "daemon started successfully". I've tried restarting my computer, my phone and the adb connection, still same thing.

This is the command I tried:

adb push "D:\Pictures and Videos" "storage/A01D-69AC"

Phone Model: Xperia 1 III
SD Card: Toshiba Exceria 256 GB

8
  • expected behaviour, no permissions
    – alecxs
    Dec 16, 2022 at 13:21
  • @alecxs thank you, do you happen to know what i need to do to fix that?
    – Grey Bunny
    Dec 16, 2022 at 13:25
  • @alecxs does not seem to be a permission problem, i manage to move single files using the same command, might just be a size issue
    – Grey Bunny
    Dec 16, 2022 at 13:33
  • How old is the SD-card? What file-system is the SD-card formatted with? As it is larger as 64Gb it should be formatted as FATex by default.
    – Robert
    Dec 16, 2022 at 16:06
  • @Robert i am using toshiba exceria 256 gb exFAT formatted, the sd card is about half a year old.
    – Grey Bunny
    Dec 18, 2022 at 3:46

1 Answer 1

0

Remove the spaces in the folder in your computer.

then do this:

adb push D:\PicturesandVideos /storage/A01D-69AC/

1
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 18, 2023 at 19:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .