3

Currently, the tablet seems to be in a chicken and egg situation:

Can't login to google (presumably) because of outdated software (we get a "invalid login" message, but the credentials are valid -- we tested on a computer), can't update the software because of lacking login to google.

So I ask: what should be installed to fix this? Perhaps a new version of google play, or that google services package? Would it be prudent to download those APKs from somewhere else instead of the google store?

I also presume that the most recent versions would not run. So what would be the latest versions that would accept to run on 4.04?

2
  • 3
    Plain Android 4.0 does not support TLS1.2 which is required for PlayStore access. Google has developed a workaround with a custom TLS library but I don't know how it is deployed. The only way I see is to install an updated version of Google Play Services and Google PlayStore. As updates have to have the same signature you can not install a manipulated or otherwise non-genuine app as update so matching APK files from third party websites are not a big risk (if the downloaded app is really an update).
    – Robert
    Dec 26, 2022 at 22:04
  • 2
    According to this news, Google Play services dropped support for Android 4.0.x ICS in December 2018 with v14.7.99 as the last version. There's v14.8.49 on APK Mirror that still supports Android 4.0+, you might want to try it. However, the TLS 1.2 issue is more concerning since it has only been supported since Android 4.4.
    – Andrew T.
    Dec 27, 2022 at 3:39

0

You must log in to answer this question.

Browse other questions tagged .