I'm trying to recover data (contacts mostly) from an old phone (Xperia Neo V) that was running Android 2.3.4 and so far I managed to dd the data partition via adb. The partition is YAFFS one. I would like to mount it to be able to run Recuva or testdisk over it and see if I can rescue anything that way.

Honestly, I'm not even too sure if it was possible to properly create the YAFFS partition with dd. But assuming that the process went well, how do I mount the image? I can't seem to be able to do that nor have a clue how to verify if the 420 MB file I got is a proper partition image.

Did you try something similar in the past, or maybe you have experience with this sort of stuff to guide me into the right direction?

I will greatly appreciate your help, I'm sort of desperate here, and very tired so far.

  • Does this answer your question? How to mount a yaffs2 filesystem
    – alecxs
    Dec 28, 2022 at 10:30
  • there is package mtd-utils not sure it support yaffs
    – alecxs
    Dec 28, 2022 at 10:39
  • @alecxs Thank you, I tried the mentioned URL. No, sadly nothing worked for me there: unyaffs2 segfaults on the image file I'm providing while Yaffey says that there is a missing page at the end of file. Perhaps the usual dd command is not enough to create a proper partition dump for yaffs?
    – monsune
    Dec 28, 2022 at 22:41
  • @alecxs Took me pretty long time but I at last managed to create a proper image that in fact can be viewed (not mounted) with Yaffey. The problem being that I still can't recover old/deleted versions of files. I'm specifically after contacts2.db of course.
    – monsune
    Dec 29, 2022 at 3:57
  • recovery of deleted/overwritten files is nearly pointless. however, sqlite3 files grow, there is a good chance the entries only marked as deleted
    – alecxs
    Dec 29, 2022 at 10:59


You must log in to answer this question.

Browse other questions tagged .