1

I'm trying to root my Samsung Galaxy S7 Edge, but I can't get the USB to work with MTP.

  • I've enabled USB debugging and set the USB mode to MTP, but still won't be recognized by the computer.
  • I've tried installing new USB device drivers from https://developer.samsung.com and it still didn't work.
  • I've factory reset the device, still to no avail.
  • I've also tried multiple Micro USB cables, which all have the USB Trident Trademark. None of them get recognized by my computer, and neither do they get recognized as plugged in on my laptop when I run lsusbn.
  • I've also tried getting plugging in my Samsung Galaxy S3, which I believe didn't get recognized either.

When I plug the phone into the computer, I expect to see the prompt or the notification asking to allow the computer to access the phone's data, but it never happens.

Does anybody know what could be the issue here?

3
  • 1
    Based on all of these, perhaps the USB cables are charging-only cables, not data cables. Have you tried it with other non-Android peripheral that needs to transfer data, like an external SSD/HDD/BD/DVD/CD/SD card player?
    – Andrew T.
    Commented Dec 30, 2022 at 13:15
  • 2
    What about adb? Enable it and try to connect to it (adb devices and adb shell). If this also does not work I would try to boot the PC using Live-Linux DVD and see if MTP works in this configuration. If it works it is a PC/Linux problem.
    – Robert
    Commented Dec 30, 2022 at 13:32
  • samsung microUSB differ from other usb cables. on linux no drivers required. what is lsusbn?
    – alecxs
    Commented Dec 30, 2022 at 14:46

0

You must log in to answer this question.

Browse other questions tagged .