0

So I recently rooted my Pixel 6 (Android 13) using Magisk and tried to control the CPU frequency, but it did not have userspace CPU governor. I tried to set scaling_setspeed in /sys/devices/system/cpu/cpu0/cpufreq/ with no luck. Also tried setting scaling_max_freq and scaling_min_freq using the maximum frequency and scaling_governor as performance mode, but when workloads start, the frequency would drop. Is there a way to set and fix the frequency without installing userspace CPU governor?

It was to my understanding that performance mode would keep the CPU at max frequency, but even then, that was not the case.

2
  • Are you aware that your CPU has three different core types, each with an own max frequency (2x2.80 GHz Cortex-X1, 2x2.25 GHz Cortex-A76, 4x1.80 GHz Cortex-A55). Not sure how the cpu governor handles environments with different CPU cores.
    – Robert
    Jan 4, 2023 at 11:22
  • Yeah, it's to my understanding that each core cluster can run it's own CPU governor. For example, I have the A55 clusters as performance, A76 as powersave, and X1 as sched_pixel
    – hscys
    Jan 4, 2023 at 11:41

0

You must log in to answer this question.

Browse other questions tagged .