I have a Samsung device. My friend and I were trying out the parental control feature. Even after stopping supervision, it's impossible to uninstall the parental control app and remove its restrictions

Here are some deets:

  1. I've already tried age verification
  2. Already stopped the supervision on my friend's phone
  3. Tried clearing the cache and storage of all Google apps
  4. Removed myself from the family through Play Store
  5. Tried resetting all settings, but factory reset is disabled
  6. Tried disabling parental control as a device admin, it is greyed out
  7. Unable to boot into safe mode
  8. Can't enable developer mode (so no ADB)
  9. Security certificate section is disabled
  10. Deleting my Google account is not at all an option, it's my primary account
  11. Tried changing the password of my Google account, and tried to force log out and reset using the Find My Device feature. That didn't work (it says no device registered)
  12. Tried transferring the app (Family Link) to the SD card, and removing the SD card. Didn't help, it still has restrictions
  13. Unable to reset the phone through Samsung Find My Device and through Google Find My Phone (both say my phone is not registered)
  14. On my friend's phone, it says open parental control (by going to Google in Settings) and set it up again to start supervision.
  15. Another question with a similar problem What to do when "Stop Supervision" does not stop supervision in Google Family Link. As mentioned in the answer, I tried waiting, and it's been more than 24 hours, nothing has happened, the issue still persists
  16. Tried meddling with my birthday in my Google account, but at some point, it asked me to verify my age through a card, which I did. And the age got verified.
  17. Tried to install the beta version of Family Link, by signing up through Google Play Store, hopping the beta has resolved the issue, but it didn't help
  18. Tried restarting my phone several times, but to no avail
  19. Tried hard resetting (through the recovery menu), but the phone won’t go into recovery, it vibrates at a point where it was supposed to go into the recovery menu, and boots normally and the phone turns on

My problem is my phone has become laggy and I'm not able to add Google accounts. Unable to reset my phone. Please help in removing the app Family Link.


1 Answer 1


Managed to solve my problem.

Start by backing up your phone and then perform a hard reset.


  1. Once you have backed up your data, shut down your phone
  2. Connect the phone to a computer, it should start charging your phone
  3. Now hold the volume up and power button
  4. After a couple of retries, the recovery menu will appear after the Samsung logo appears

The key is to keep retrying the procedure from step 4 until you get it

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .