4

I'm using adb sideload update.zip command, but it is stuck on serving at 0% (Verifying update package ... on phone).

I tried adb usb command, but the error is closed. The device state is sideload.

More details: I have a Samsung A03s (SM-A037F). Yesterday it suggested an android update. I accepted and after that, the phone was restarting repeatedly stuck in at the Samsung logo.

  • I downloaded the latest full update package (Build Number: A037FXXU2CVK7)and platform-tools_r33.0.3 as well.
  • I also installed the latest Samsung USB driver.
  • Then I pressed power+volume-up button to enter recovery mode. I selected Apply update from ADB

EDIT 1: I can now do a reset factory, but I need my photos and videos.

EDIT 2: When I use adb logcat , the result is just: - waiting for device - for a long time and nothing else

9
  • 1
    check current rom A037FXXU2CVK in recovery mode and csc, sw rev: b: in download mode. download proper ROM (not latest) according to the current ROM. extract files and double check HOME_CSC exist. if so, you can flash four files in Odin3 without wiping data (not CSC). if still no luck, flashing single partitions with mtkclient might possible.
    – alecxs
    Jan 21 at 19:04
  • Thank you @alecxs . I did what you mentioned at first, but no result. Would you please explain more about flashing single partition? Jan 25 at 19:50
  • won't help either. Odin flashed successfully?
    – alecxs
    Jan 25 at 19:53
  • Yes, that was successful but did not solve the problem, however thanks again @alecxs Jan 26 at 18:21
  • read back userdata partition with mtkclient python3 mtk r userdata userdata.img from pendrive. run fsck userdata.img to repair f2fs file system. if mountable, flash back to userdata partition.
    – alecxs
    Jan 26 at 19:11

1 Answer 1

0

Have you tried a factory reset?

For A30 the steps are

How to perform a hard reset on Samsung Galaxy A30 via recovery mode?

Follow these steps to perform a hard reset on your Samsung Galaxy A30 and reset your device to factory default settings.

  • Turn off your smartphone.
  • Press and hold Volume up + Home + Power buttons simultaneously till the device logo appears.
  • After the device logo , release Power button but hold the others a few more seconds.
  • Release all the buttons when Recovery mode screen appears.
  • Go to Wipe Data / Factory Reset option using Volume Down and press Power button to confirm it.
  • Go to Yes –Delete All User Data using Volume Down and press Power button to continue.
  • Recovery screen will appear after formatting process. Then, press the Power button on Reboot System Now to restart.

From factoryreset.net

I am not associated with this site in any way.

2
  • If an Android updates goes wrong I assume side loading a full OTA firmware is an attempt to recover the phone without data loss, so I don't think a factory reset is what the OP wants...
    – Robert
    Jan 21 at 13:13
  • Thank you dear Rohit. As dear Robert mentioned, I really need my data and don't want to do a reset factory. Thank again for editing my question Jan 21 at 18:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .