I'm trying to use an aux cord, but my Samsung Galaxy S21 Ultra does not come with one.

I got a USB-C adapter, but when plugged in, it says the connected USB device isn't supported. I've tried to go thru the developer options, but none have worked. I'm currently at *#0808# but have not the slightest idea what each means.

menu on samsung 21 ultra *#0808#

When I watch videos, other phones don't have all these other options, so it's kind of like I'm just trying to use aux on a phone that has no aux option.

  • 1
    All the settings shown on your screen shot are only relevant if you connect your phone to a PC (PC = USB master, phone = USB slave). But an USB-Aux adapter will always run as a USB slave, thus the phone has to become USB master and so all of these modes are irrelevant for the adapter.
    – Robert
    Feb 15 at 8:20

1 Answer 1


From what I could find the adapter has to specifically have an integrated DAC(Digital to Analog Converter). You can read a full discussion here that applies for the S21FE so it is safe to assume it will apply to the S21 Ultra.

I have a Note 10 and observed one day that I got prompted for a firmware update for the wired USB-C headphones that came included with the phone. This shows that they are not using an analog signal and there is some sort of integrated chip in the connector(I always thought that they were just simple analog headphones). Picture of the headphones so you can see that they are the most basic of basic headphones. :)

This article was also helpful when searching why the issue would occur. It explains how analog audio works on USB-C when implemented.

The problem might be that the adapter that you have uses the analog implementation for audio but the phone only supports digital.

Also check the Media Output in the dropdown bar, as outputting audio should not require you to enter USSD codes(**#0808#* that you mentioned in your post.) I attached a photo of how it looks on my phone and highlighted it. enter image description here

I don't have an adapter to test this but in my opinion this might be the cause.

I hope this is helpful and you manage to fix the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .