3

There are a lot of very old answers to this question, and they are not helping me.

  • I am running MacOS Venture 13.2.1
  • I have a Pixel 4a running Android 13 patched to March 2023
  • I have Android File Transfer 1.0.12 which is the latest stable version available
  • I have never had a Samsung phone so haven't installed Kies.
  • When connecting the USB cable I get a notification and can select File transfer/Android Auto
  • The same USB cable is working fine with Windows. The USB port on my Mac is working fine with a hard drive.

I am able to connect to the phone using ADB but don't want to use ADB to transfer files all the time when there is a simple GUI that allows this.

I am having the same issue on my Windows computer, so I am wondering if there is some setting on my phone I have missed.

Update - I am able to access files on my phone via Windows fine after all. I see MTP showing up in Devices, and can see my Phone by it's name in File Explorer.

Update 2: I apologise for not giving more detail about what does happen. When I connect my Pixel 4a to my Mac Android File Transfer does not open automatically. When I run it manually, I get a message saying 'No Android device found. The phone detects the connection (hence the USB mode notification, but it seems the Mac does not.

3
  • 1
    Have you tried alternative apps like OpenMTP? May be the Android File Transfer program is juts buggy or incompatible with the used MacOS version.
    – Robert
    Mar 27, 2023 at 11:07
  • What are the symptoms? AFT crashes? hangs? Fails to launch? Gives some error, if so what? Etc. May 17, 2023 at 6:06
  • @Robert OpenMTP and uninstalling Android File Transfer did the trick! OpenMTP's docs were helpful in identifying that Google Drive, OneDrive and other apps (Calibre?) could also tie up the USB connection to my phone.
    – dunxd
    May 18, 2023 at 11:40

1 Answer 1

2

It turns out that a number of applications can block access to USB connections to my phone - here are the applications I exited:

  • Google Drive
  • OneDrive
  • Calibre

I figured this out through installing OpenMTP as suggested by @Robert in a comment - its in your face documentation was really helpful.

Closing the above apps allowed both Android File Transfer and OpenMTP to access my phone.

I then experimented with running the above listed apps one at a time to see if they interfered with Android File Transfer.

  • OneDrive definitely causes the issue
  • Google Drive definitely causes the issue
  • Calibre does not cause the issue, (and can be configured to ignore USB devices if it detects them - wish that OneDrive and Google Drive could do that!).

I didn't have this problem with my previous phone for some reason.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .