Starting yesterday, my Galaxy s2 device running Cyanogenmod 9 started to crash with android.database.sqlite.SQLiteDiskIOException exception for every running app. Does it means that my phone is dead or I can fix it?

I was using an old cyanogenmod nightly on the device, and updated to cyanogenmod 9 rc1 after the problem started just in case, and it didn't helped me at all.

  • Did you try a factory reset? Commented Jun 30, 2012 at 7:01
  • 1
    @MatthewRead I prefer not to do a factory reset as I do have some data on the device. I've formatted the Cache and Dalvik Cache from the recovery, though. Commented Jun 30, 2012 at 8:24
  • 1
    Report it to Cyanogenmod team. :)
    – t0mm13b
    Commented Jun 30, 2012 at 14:08
  • Have you checked your free disk space? Commented Jul 6, 2012 at 12:48

2 Answers 2


I encountered exactly the same problem as yours on my Galaxy S2 with CM9 earlier this week.

I figured out it might be the problem that the internal USB storage had some error on it.

Unfortunately, formate Dalvik Cache and Cache won't fix the problem.

You can try to mount your phone onto your computer and try to fix the error using some disk check utilities, which I tried but phone freezes after mount as USB.

At last I fix the problem by doing a hard reset. So I suggest you start from trying mount your phone to your computer and do some quick backup first.

If you cannot even copy out your files, it is the problem of internal USB storage with some logical errors.


It's probably too late to help the original poster, but I had this exact same problem for the past 24 hours or so on my HTC Incredible with Cyanogenmod 7.1.0. I was consistently getting SQLiteDiskIOException errors every time I tried to start an application, including even the keyboard and crash reporters.

After stopping and uninstalling all sorts of applications, I finally happened to clear the Twitter client data through Manage Applications. It immediately solved the problem. I'm not sure if it's Twitter itself, or if clearing the data managed to tweak something else.

Anyway, something for someone to try if they run across this error. I was one step away from reinstalling the OS from scratch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .