SOLVED (see accepted answer)

So this one is weird.

Everything was working fine untill I rebooted my phone earlier today.

For some reason, since this reboot, apps are unable to access my SD card storage. As far as I know, no update was applied with this reboot. I do not recall tinkering or changing anything related to this recently.


  • SD card is still visible in the storage tab of the settings (there is no available option to unmount or eject it) or in select cases when choosing a folder from an app, however the content does not show up past the root.
  • My music player (Oto music) sends an error message "Cannot play this file" while trying to play a song from the SD card
  • File explorer will not show the SD card directory at all
  • Resillio Sync has a synced folder on the SD card. It now says "Can't open the destination folder". If I try adding a new synced folder on the SD card and select the root of the SD card, I get the message "Android OS restricts access to this folder"
  • Google file is stuck in a loop trying to get permissions to access the card
  • SD card works just fine on another phone.
  • Other SD cards have the same problem with my phone, not just this one
  • SD card does not show up when using file transfer with a Windows PC
  • Rebooting the phone did nothing
  • Removing the card and putting it back in again did nothing
  • Formatting the card did nothing
  • I factory reset the phone. It worked, but the problem came back at the first reboot.

Current state of investigations I have reset the phone a second time and reboot it every time I install an app, uninstall or disable a system app or change some settings. So far the SD card is still accessible so I know what it's not:

  • it's not the fault of disabling system apps
  • it's not related to using a work profile (Insular)
  • still haven't found an app that causes it

I have no idea what could cause this, all I know is it's related to my phone in particular and it appeared out of nowhere.

I am using Android 13 on ColorOS.

Thanks to anyone who can help.

  • 1
    If you wouldn't have checked multiple SD-cards my guess would have been a defect SD-card, but not this isn't an option. Thus the only other alternative I see is a problem with the SD-card reader. Have you tried to completely power down your phone (not reboot, really put it off). Some times independent controllers go mad and some of them are not reset by a reboot, only by a power off.
    – Robert
    Commented Apr 13, 2023 at 20:36
  • @Robert I have powered down the phone entirely but maybe didn't do it for long enough. Anyway, I have also tried to factory reset the phone. It worked, but at the first restart the problem was there again. I am suspecting an issue with the firmware.
    – Weiur
    Commented Apr 14, 2023 at 14:20

1 Answer 1



Found the thing! This bug is caused by activating the option Disable permission monitoring in the Developper Options.

This is an option that is specific to a handful of phone manufacturers (Oppo in my case). Enabling this option is needed for using some tweak apps such as Shizuku. However, if it is enabled on phone boot, SD card will be unaccessible.


Disabling this option and rebooting the phone fixed it. If you still need to use this option, you can enable it while the phone is on and disable it before rebooting. It will work fine despite this minor inconvenience.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .