1

I am on a Fairphone 3 and run /e/os 1.9.

Background

I recently started to run out of disk space each time one of my apps (Signal messenger) started to create a new backup, as my free space was not large enough to accommodate a new backup file. Yesterday I turned off the phone when I saw that the "little storage left" notification came up and the backup was running, and put a brand new micro SD card in the phone that I had meant to set up since a while. After powering up the phone again, the notification for low storage was (non-surprisingly) still showing, alongside with one for the new SD card. When I opened the SD card I saw that a lot of empty folders had been creating, mirroring the ones in my internal storage. The phone also started to vibrate repeatedly and showed "No log (file) could be created" in a small popup on the bottom of the screen. I decided to ignore that and try to move some files from the internal storage to the SD card to free up some space. After a short while, the phone crashed and rebooted into recovery.

Problem

When I power up the phone, it boots into recovery, showing this screen:

Recovery 
Version 1.9 () 
Active slot: a

Can't load Android system. Your data 
may be corrupt. If you continue to get 
this message, you may need to perform 
a factory data reset and erase all 
user data stored on this device.

> Try again
Factory data reset

I can also navigate back into a recovery menu. When I select try again, the phone starts up as normal. I get then to unlock my SIM. However, as soon as try to unlock the normal lock screen for the first time, the phone will crash.

If I just try to unlock the screen, an empty home screen will show for a moment, before my normal home screen loads (I use lawnchair as a launcher, which is not /e/os default). Then, sometimes a popup comes saying ??? launcher crashes all the time, partially obscured by an other popup saying Power off. The phone will then reboot into the recovery.

If I try to directly go to the settings page by swiping down and clicking the settings shortcut, that page is shown for a second or two before the phone also powers off and reboots into recovery.

If I click on the "Out of storage" notification, the same thing happens.

I would really like to prevent losing my data.

What I have tried so far

It appears like I can't do anything after unlocking my phone, as it will reboot directly.

I have gone through the recovery and fastboot menus, trying to find anything that could be of help. I was able to activate ADB and browse around in the file system using adb shell, but none of my personal files where accessible and there was apparently a lot of space available on that partition. I was also able to mount system from an option in the recovery. Even this partition showed only 73% disk usage. It was also read-only, so I was not able to remove any files. The sdcard folder in both / and /mnt/system/ was empty.

The recovery also gives me the option to install an update, e.g. via adb sideload. I have not tried that, since I don't know how to do so and if it will give me access to my personal data.

What to do now?

If this would be a computer, I would use a live linux system to run fsck and similar tools to identify and repair the corrupted data and to free up some disk space. Is it possible to do something similar with my phone, for example using adb?

Is there any way to access/recover and possibly back up my personal data?

8
  • you should enable usb-debugging and run the stop cmd. then the phone won't reboot so you can pull files (and uninstall some apps?) from adb. maybe remove sim or put in airplane mode gives you enough time to enable usb-debugging
    – alecxs
    Apr 14, 2023 at 7:01
  • Thank you for the tip! I tried for a while now to activate usb-debugging, but without any change. No matter what I try, as soon as I unlock the device (even without sim and in airplane mode) it reboots before I am able to actually press anything. Apr 14, 2023 at 10:23
  • check from fastboot if DEVICE STATE - unlocked (in that case you can install TWRP)
    – alecxs
    Apr 14, 2023 at 11:07
  • No, device state is unfortunately locked. I also tried mount data from adb in recovery mode, but got the error that data was not in fstab. Apr 14, 2023 at 11:15
  • I don't know what your recovery is capable of, stock recovery cannot decrypt data and therefore not mount data
    – alecxs
    Apr 14, 2023 at 12:00

0

You must log in to answer this question.