0

I have a degoogled lineageos phone. I'd like to be able to play "A dance of fire and ice" and "cytus" on this device.

If I have previously purchased these apps, I think I should be able to install them through the aurora store (Or worst case, extract an apk from another device and install it). The only problem is that I don't actually own any android devices with gapps to purchase these apps on, and the play store web interface doesn't let me purchase an app if I am not logged in on any eligible devices.

Therefore I decided to set up a waydroid install with gapps, to try and get this stuff to work. However, after having done this, and navigating to the store page I see: "This app won't work for your device", and when I go to the web interface, I see the following:

enter image description here

Of course android is being its usual opaque self, and not actually telling me why it "won't work on my device".

I think I might be able to fix this by setting up waydroid in such a way that the playstore thinks that my device is in fact compatible with this app, just that I have no idea what it wants me to do for it to accept this app. Is the screen resolution wrong? Wrong android version? Something else entirely?

I already purchased a play store gift card which I can't return anymore. Therefore there is no use in giving up because something might not work. I was willing to take the gamble when I bought that card in the first place anyways

7
  • 1
    The app is not paid, but uses in-app purchases. In-app purchases require Google services to work. Not sure what happens if the app tries to access Google services to check the license and your in-app purchases and it does not exists. A crash is very likely.
    – Robert
    Apr 22, 2023 at 12:42
  • A dance of fire and ice is paid, also, I should have said cytus II instead of cytus, cytus is indeed not paid but has in app purchases.
    – TT-392
    Apr 22, 2023 at 12:47
  • 1
    For third party apps you should better directly link to the PlayStore entry. Your screen shot shows that it has in-app purchases (and it is additionally a paid app). Note that Google recommends for paid apps to perform a license check at start-up to avoid illegal distribution of paid APK files. This license check is similar to an in-app purchase check and for both AFAIK Google services are needed. developer.android.com/google/play/licensing
    – Robert
    Apr 22, 2023 at 12:52
  • 1
    You can try to install Android Emulator from Android SDK. Google provides emulator images with built-in Google services and Play store. Buying apps in the emulator should be possible. It would be at least worth a try if the app you want is available in that environment or not.
    – Robert
    Apr 22, 2023 at 13:09
  • 1
    Based on the screenshot, it seems Waydroid is using an x86 image which is very rare nowadays, and rarely supported on games that depend on native libraries. Consider trying an ARM image instead.
    – Andrew T.
    Apr 22, 2023 at 13:59

1 Answer 1

1

Robert's comment seems to have fixed it (I used the emulator built into android studio, which I happened to have already installed, with a device that has the play store installed). I guess the reason waydroid didn't work is because it was on an x86_64 device, like Andrew T. mentioned.

Either way, I managed to couple that emulated device to my phone, and I was then able to purchase a dance of fire and ice through the google play web interface. After doing this, I could just install the app through aurora, on which I am logged in with my google account. This works, and I am now happily playing a dance of fire and ice on my degoogled device. Though I wouldn't be surprised if not all apps allow you to just run them like that without gapps.

update: tried cytus II as well, this one didn't work.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .