I'm looking for some help in finding a workaround for the pixels (6 pro, 7) dropping 5g nr connection due to lack of ims registration on Android 13 and 14.

  • My device is running build: tp1a.221105.002

  • Update: also tested on tq2a.230505.002; problem persists.

  • Borrowed a friends Pixel 7 running android 14 and the problem still exists on even the newest Android.

  • Pixel 7 was a friends device running the latest.

  • Pixel 6 is working fine on Android 12. (I wish I could just roll back like we could in the old days...)

Test setup:

Ubuntu 22.04 desktop
Open5gs core
SRSRan_Project running on a b210, transmitting inside a Faraday cage
USB C connect to phone through Faraday Cage USB port
Running scrcpy to monitor phone visually in parallel with "logcat -b radio"

So far I've tried using the *#*#0702#*#* ims menu. I futzt around with a menu called, "Edit Ignored CarrierConfig Filter". Tried a few registrations with a handful of ims registration related toggles.

The most promising was: ims.ims_registration_required But it didn't fix the issue. Still getting PDU sessions and just losing connection after a few minutes.

For more details check out the GitHub logs, but in human speech; The device registers just fine according to the amf. The UE is even assigned a PDU session and I can access the internet to watch YT or ping around the network. But after 1~5 minutes (always random) the UE will use drop connect. The amf logs don't show a reregistration or UE-idle message either.

For comparison sake, I used a gold standard pixel 5 and pixel 6 running Android 12 and they work fine. Additionally, I found an S22 to try running Android 13 and that phone stays connected for hours when testing.

Before I set out to build the ims server using Kamailio, I wanted to make sure the phone didn't require it. When I move to 5g handovers I'd like to isolate the test using the RSRP to trigger by itself and not have to get lost in the ims networking handover also.

Thanks in advance for all the help! P.S. I wrote this in a bit of a hurry. I'll make some edits around lunch.

  • Update: Rerooted the Pixel 6 with tq2a.230505.002 Problem persists. Borrowed a friends Pixel 7 running android 14 and the problem still exists on even the newest Android. May 5 at 17:36
  • Does this commit help?
    – kyrlon
    Jul 7 at 14:06


You must log in to answer this question.

Browse other questions tagged .