0

I can flash using Realme tool on my Realme X2 (rmx1992) but even after successful flashes it boots into fastboot no matter what I select to boot in.
I tried fastboot continue, but nothing.

I have messed recovery and vbmeta but all those get re-written after every flash so it doesn't matter right?

Previously I did flash the same rom and twrp successfully (was working okay) so it isn't the roms.
Condition before this happened: I tried flashing twrp and it just stuck in fastboot

Edit: Tried flashing the partitions one by one. Same issue.

0

1 Answer 1

0

I found that Realme Flash tool is a poor segway for flashing. It works most of the time at normal soft bricks or for simply flashing an OS.

This github OFP flash tool by Italo Almeida (and bkerler) is a life-saver!
Basically, all it does is simply flashes all the partitions one by one (with some additional logics/tweaks? I don't know)

Many of the images failed to flash (including obm, opporeserve2, etc) But it worked.
Flashing the same image through Realme Flash Tool prompted "flash error cannot find central directory" (i.e. the rom is not compatible with the device (as Google searches suggest)) But here I am with the same rom perfectly working on my device.
Manually flashing recovery, vbmeta, vendor did not help get out of the bootloader and enter recovery

You can also keep a backup of recovery and vbmeta in case you mess up. Or just extract it from the ofp rom and flash. tool by bkerler again.

This helped a lot (however, I didn't have a problem with ab partitions)
ROMs (just in case)

Check my answer here:
Cannot enter bootloader?

4
  • "flash error cannot find central directory" may indicate that the used ZIP file is truncated (central directory is at the end). Alternatively most ZIP files can be read in "streaming mode" which doe snot need the central directory at the end. May be the OFP flash tool read it that way and thus can use it.
    – Robert
    May 4, 2023 at 9:54
  • @Robert That makes sense.. I did not know about the suggested streaming mode. I'll look that up. Thanks!
    – 44yu5h
    May 4, 2023 at 9:59
  • If it is a ZIP file try to use a ZIP checker tool. If it is really defect you should get a similar error about it's central directory.
    – Robert
    May 4, 2023 at 10:07
  • @Robert No it's not really a zip file. It's an encrypted file that contains a bunch of flashable images with a guidelines-type text file that gets flashed on the device accordingly. We can decrypt it using a key. It exactly sounds like a zip file. It is a zip file. Used by Realme/oppo for packing their roms into a lump. The roms are usually not defective :)
    – 44yu5h
    May 4, 2023 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .