I'm using a Xiaomi MI 9 SE phone (Android v11, MIUI Global v12.5.1). For quite a long time now, I've had the problem of not being able to open PDF files attached to WhatsApp messages I receive. When I double-click them, the app I choose either shows nothing, or immediately quits (depends on the app).

I tried to check the app permissions, and there are no permissions - that I know off - that WhatsApp is missing. I also tried updating WhatsApp, which didn't help.

I do not have this problem with other messaging applications, e.g. Telegram. Also, the different viewers / handling apps are able to open PDFs from other sources.

What's the cause of this problem, and what can I do about it?

Note: My situation is not the same as in Cannot open PDF files received on WhatsApp directly, where the user was getting an error message about not having the appropriate app for the content type.


1 Answer 1


The answer eluded me for many months, and then somehow I stumbleds upon it in this reddit thread...

Just (re-)enable MIUI Optimizations.

To be honest, there's probably some kind of bug in MIUI in the no-optimizations situation, where it mis-handles handing off PDFs and other files from one application to another, so that's more of a workaround than a proper solution. But - it works. You'll notice that the dialog you get when you click a PDF file is different than before, and if you select an app (possibly via a '...' button) - it will actually open the PDF.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .