0

I'm using Lineage 20, Android 13 on a Pixel 4A and often when I'm using the hotspot feature while charging I get a notification with the message "Your phone is getting warm".

It then disables stuff like the hotspot for some time until it decides my device is not warm anymore.

When touching the casing with my hand it doen't feel warmer than usual and even then I want to choose if my phone should die early from overheating so I'm looking for a way to disable this "feature".

Thanks for your assistance !

5
  • FYI, documentation from AOSP: source.android.com/docs/core/power/thermal-mitigation Just be aware that charging a battery and running the radio as a hotspot generates quite a bit of heat. May 13, 2023 at 3:16
  • 1
    What charger do you use (what voltage and ampere does it provide)? An easy mitigation would be to use a charger with less power as this reduces the heat created by charging. Additionally I would build a stand where the phone can stand on its long border and additionally is in the air flow of a fan.
    – Robert
    May 13, 2023 at 7:27
  • @Robert I'm using a 5V/3A charger on a Pixel 4A (i'll add it to main post sorry), the stand is a great idea but the body of the device doesn't feel hotter than usual at all, I doubt it'll fix the issue
    – hollow
    May 14, 2023 at 20:52
  • @MorrisonChang Thanks for the AOSP documentation, I'm gonna look for a way to disable the mitigation of the emergency level in the ThermalManagerService
    – hollow
    May 14, 2023 at 20:58
  • @Hollow Do realize that the warning is a safety feature to avoid damaging hardware. Unless you are using a thermal camera and know that the device or a certain component like the radio is throttling incorrectly, finding a way to reduce the temperature of the device during operation, like a cooler ice block or using active cooling case/attachment is something to consider. May 14, 2023 at 21:07

1 Answer 1

0

It's normally the battery that starts getting warm. The automatic cooling of it is a safety feature. I have only ever had this when in a cradle in the car, charging the phone, while using a driving app, and with the sun shining on it.

  • If you have a cover, take it off.

  • A slower charger (as mentioned in the comment) would help.

  • If you are not traveling at that time, turn off the GPS.

  • Some Providers limit the length of the hotspot and automatically connect.

  • Hotspot Settings has options for Auto turn off and data limits. Check these by doing a long press on the hotspot name followed by dropping down Advanced Settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .