0

I wish to connect via ADB to a Samsung Galaxy A20e, but my computer won't detect the phone. I'm running Arch Linux and lsusb doesn't show anything about this phone when it's connected via USB.

What I've tried:

  • enabled USB Debugging in Developer Mode
  • set "Transferring Files" as the Default USB Configuration
  • set "MTP + ADB" in the view that appears after dialing *#0808#
  • tried different USB cables on different USB ports and even on different computers (all running Arch Linux though)

But still nothing: lsusb remains unaware of this phone.

What else can I try to get a Samsung Galaxy A20e to communicate with my computer so I can use ADB?

3
  • 1
    I would boot into a "standard-distribution" live-Linux system (like Ubuntu) and check if it also can not detect your phone. If it is not detected a hardware defect on the phone is very likely.
    – Robert
    May 24, 2023 at 9:36
  • 1
    Welcome to Android Enthusiasts. Looks like there's an official wiki for using ADB on ArchLinux. Have you tried it?
    – Andrew T.
    May 24, 2023 at 11:00
  • Try "sudo lsusb" Sep 12, 2023 at 21:48

0

You must log in to answer this question.

Browse other questions tagged .