I tried to root my Oneplus 6T. Now the phone is stuck on the bootloader

If I continue with START, the device is going to a loop, never completing the boot process.

I tried booting the boot image with fastboot like fastboot flash boot twrp-3.2.3-1-fajita.img, but after that, an error message is displayed

QUALCOMM CrashDump Mode  

Attempted to kill init!  exitcode=0x0000000b

After searching, I found that the MSM tool can flash the device with a fresh install, but the software is not available on macOS.

Is there any alternative for the MSM tool? How can I get at least go back to a non-rooted state?

  • I don't know the resolution, but you can install VirtualBox or a VM and install Windows on it. plug in the Android/ install the software in the VM; it should work if it needs windows.
    – Big Joe
    May 24 at 20:40

1 Answer 1


After an extensive Google search and reading xda forum, I realized that the official TWRP image does not support the latest OxygenOS -

Fortunately, there is an unofficial patch that works on OOS I got it from this thread. After flashing the newly downloaded image, I could boot to TWRP recovery.

  • Welcome to Android Enthusiasts. Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Consider editing to summarize the content and/or expand the answer!
    – Andrew T.
    May 25 at 4:21
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    May 25 at 16:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .